Closed Bug 1567640 Opened 2 years ago Closed 2 years ago

./mach build should build |android build-geckoview_example|

Categories

(GeckoView :: General, task, P3)

Unspecified
All

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1550146

People

(Reporter: agi, Assigned: fluffyemily)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

./mach build on an android build only builds application code, but not tests. We should make ./mach build build everything that ./mach android build-geckoview_example builds too.

(In reply to Agi | :agi | ⏰ EST | he/him from comment #0)

./mach build on an android build only builds application code, but not tests. We should make ./mach build build everything that ./mach android build-geckoview_example builds too.

Around https://searchfox.org/mozilla-central/rev/96403eac4ff6f96f89a0b120b29bd46540d5705e/mobile/android/gradle.configure#127, add lines like

https://searchfox.org/mozilla-central/rev/96403eac4ff6f96f89a0b120b29bd46540d5705e/mobile/android/gradle.configure#280
and maybe

https://searchfox.org/mozilla-central/rev/96403eac4ff6f96f89a0b120b29bd46540d5705e/mobile/android/gradle.configure#327

mach build should build everything, including GVE and the tests.

Priority: -- → P3
Assignee: nobody → etoop

This patch builds geckoview example app and the geckoview tests when you run ./mach build. It increases the export phase of the build process, but catches exceptions in both places and it Java and Kotlin.

This was addressed by Bug 1550146.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1550146
Attachment #9081291 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.