Closed Bug 1567714 Opened 2 years ago Closed 2 years ago

"Switch to tab:" text contrast ratio is too low when Firefox is in dark mode

Categories

(Firefox :: Theme, defect, P3)

68 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: billdillensrevenge, Assigned: ntim)

References

Details

Attachments

(2 files)

Attached image switchtotabdmcr.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Qhen Firefox is in dark mode, the "Switch to tab:" text that sometimes appears beside the URL, the text contrast ratio is too low. Please see attached screenshot (I added red arrow pointing to it)

Component: Untriaged → Theme
Priority: -- → P3
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 1574736
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32488e3b4c08
Fix .urlbar-display text color on themes. r=dao
Assignee: nobody → ntim.bugs
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Comment on attachment 9086853 [details]
Bug 1567714 - Fix .urlbar-display text color on themes. r=dao

Beta/Release Uplift Approval Request

  • User impact if declined: See screenshot.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
    • Open a tab with url "google.com"
    • Open another tab and select it
    • Type "google.com" in the urlbar
    • select the "google.com" switch to tab item in the autocomplete
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small self-contained CSS updates
  • String changes made/needed: none
Attachment #9086853 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Confirming this issue as verified fixed on 70.0a1 (buildID: 20190821215524) . Verified using Windows 10x64 , macOS 10.14.6 and Ubuntu 18.04x64.

The "Switch to tab:" is now visible while browser is in Dark Mode.

Status: RESOLVED → VERIFIED
Blocks: 1575822

Comment on attachment 9086853 [details]
Bug 1567714 - Fix .urlbar-display text color on themes. r=dao

Improves contrast for text in dark mode. Approved for 69.0b16.

Attachment #9086853 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Confirming this issue as verified fixed on 69.0b16 (20190822210915). Verified on Windows 10x64 ,Ubuntu 18.04x64 and macOS 10.14.6. The "Switch to tab:" is now visible while browser is in Dark Mode.

Flags: qe-verify+
Duplicate of this bug: 1575443
You need to log in before you can comment on or make changes to this bug.