Closed Bug 1567746 Opened 1 year ago Closed 1 year ago

OSX Mojave (10.14) - browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | Test timed out -

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1565738

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

Filed by: egao [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=257575247&repo=try
Full log: https://queue.taskcluster.net/v1/task/cZ2s4qNUQnuVAQqmK6yhaw/runs/0/artifacts/public/logs/live_backing.log


Platform: macosx1014
Suite: mochitest-browser-chrome

Context:
08:20:20 INFO - TEST-START | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js
08:20:21 INFO - GECKO(1846) | TEST DEVICES: No test devices found (in media.{audio,video}_loopback_dev, using fake streams.
08:20:21 INFO - GECKO(1846) | TEST DEVICES: No test devices found (in media.{audio,video}_loopback_dev, using fake streams.
08:20:21 INFO - GECKO(1846) | TEST DEVICES: No test devices found (in media.{audio,video}_loopback_dev, using fake streams.
08:20:22 INFO - GECKO(1846) | 2019-07-21 08:20:22.012 firefox[1846:25311] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
08:21:05 INFO - TEST-INFO | started process screencapture
08:21:06 INFO - TEST-INFO | screencapture: exit 0
08:21:06 INFO - Buffered messages logged at 08:20:20
08:21:06 INFO - Entering test bound test
08:21:06 INFO - Buffered messages logged at 08:20:21
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | should start the test without any prior popup notification -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | should start the test with the control center hidden -
08:21:06 INFO - getUserMedia audio+video
08:21:06 INFO - requesting devices
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | webRTC-shareDevices notification shown -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | notification panel open -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | notification panel populated -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | expected notification getUserMedia:request -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | anchored to device icon -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | microphone selector visible -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | camera selector visible -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | screen selector hidden -
08:21:06 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | panel using devices icon -
08:21:06 INFO - Buffered messages finished
08:21:06 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | Test timed out -
08:21:06 INFO - GECKO(1846) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
08:21:06 INFO - GECKO(1846) | MEMORY STAT | vsize 7585MB | residentFast 324MB | heapAllocated 97MB
08:21:06 INFO - TEST-OK | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | took 45073ms
08:21:06 INFO - Not taking screenshot here: see the one that was previously logged
08:21:06 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | Found a tab after previous test timed out: https://example.com/browser/browser/base/content/test/webrtc/get_user_media_in_frame.html -
08:21:06 INFO - checking window state
08:21:06 INFO - GECKO(1846) | must wait for focus
08:21:06 INFO - GECKO(1846) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
08:21:06 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
08:27:16 INFO - Buffered messages finished
08:27:16 ERROR - TEST-UNEXPECTED-TIMEOUT | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js (finished) | application timed out after 370 seconds with no output

See Also: → 1567656
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1565738
You need to log in before you can comment on or make changes to this bug.