[RFE] Autosave in mail compose editor

VERIFIED DUPLICATE of bug 16360

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 16360
16 years ago
10 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [EDITORBASE])

(Reporter)

Description

16 years ago
STEPS TO REPRODUCE
   1. Use the mail compose editor.
   2. Crash.
   3. Rewrite your mail.

ACTUAL RESULTS
   Annoyed user.

EXPECTED RESULTS
   No crash (but that's another bug). If there _is_ a crash, then the text 
   should be saved somewhere.

SUGGESTED REQUEST FOR ENHANCEMENT
   It would be really nice if the editor could autosave the composer editor's 
   contents every line or two. That way, while we wait for our crashes to be 
   fixed, we at least don't have to waste our time with lost e-mails.

I don't normally request workarounds, but these crashes show little sign of
being fixed, since we've been dealing with them for years now, so maybe in this
case a workaround would be good... autosave is probably not a bad idea anyway.

Where the autosave file should go is unclear -- but I think in the profile
directory would be best, as that will already be as secure as the user's most
private Mozilla-related data. The files should be uniquely named so as to avoid
clashes when there are multiple compose windows open. If Mail is restarted while
there are existing autosave files, it should reopen composer windows on them.
(Reporter)

Comment 1

16 years ago
I just lost an e-mail because of a crash in a totally unrelated part of Mozilla.
(The Flash plug-in running in a Browser window.) That's an argument for
splitting Mozilla into many processes more than for autosave, but in the
meantime, it's still an argument for autosave.

Comment 2

16 years ago
Agreed! Good idea, but isn't this a duplicate of
http://bugzilla.mozilla.org/show_bug.cgi?id=16360 ?

Anyway, this should also apply to NEWS post compose and not just mail.

For me it crashes sometimes with the spell checker or because I sign (by regular
certificates or enigmail-GPG/PGP) messages by default.

Updated

16 years ago
Whiteboard: [EDITORBASE]
(Reporter)

Comment 3

16 years ago
Partly because of the lack of this feature, I've now gone back to using Pine.

Comment 4

16 years ago
duplicate of bug 16360

*** This bug has been marked as a duplicate of 16360 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
verify dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.