Selecting (by dragging) the space beneath a block element scrolls the page far down

RESOLVED DUPLICATE of bug 54538

Status

()

Core
Selection
RESOLVED DUPLICATE of bug 54538
16 years ago
14 years ago

People

(Reporter: alge, Assigned: mjudge)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Linux/2002070915:
To reproduce, go to URL, scroll down a couple of songs, then select (by
dragging) the space beneath the <h2> tag (song name). Browser will scroll far
down. Actually, it seems it scrolls further down the longer down on the page you
are before you do it.. *ponder* (Use a different Style if you don't like the
default - Tristes is quite nice, or basic page style..) 

If you didn't get that, Jesse@#mozillazine described it as: 
01:38 < Jesse> alge: if i drag into the space between the <h2> and the text
below it, moz scrolls as if it thinks that space is at or below the bottom of
the page. that also happens if i start selecting in that space. it doesn't
happen if i just select text in the <h2> or if i select in the empty line above
the <h2>.

This also happens at imdb.com, when reading user-contributed reviews of movies.

Comment 1

16 years ago
WFM with 2002113012/win2k/1.2.1

reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.2.1)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.

Comment 2

16 years ago
No response from reporter for >30 days. resolving WORKSFORME.

Reporter: If you can reproduce this with a recent build of Mozilla, then please
reopen this bug and give details. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
hmm. still happens. changed the url since the last thing is was a 404.
Just select some text, you'll see it. and since there were no <h2> tags on the
imdb-page I changed <h2> to block elements in the summary.

build 2003010208/linux.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: Selecting (by dragging) the space beneath a <h2> scrolls the page far down → Selecting (by dragging) the space beneath a block element scrolls the page far down

Comment 4

16 years ago
WFM on MacOSX/2003031211
WFM Win XP 2003040508.
Assignee: attinasi → other
QA Contact: petersen → ian
(Reporter)

Comment 6

15 years ago
Guess this is linux/unix only, then. Still happens with 2003040222/linux.
OS: All → Linux
Pehaps this bug needs clearer steps to reproduce, but I cannot reproduce it in a
current Linux trunk build.... If you _can_ please give useful steps like the
exact text and location in it to start dragging, the direction to drag in, and
the place to drag to.
(Reporter)

Comment 8

15 years ago
Hmm, ok. 
1. Go to the url ( http://us.imdb.com/CommentsShow?0167261 )
2. Scroll about halfway down on the page.
3. Start selecting text right above any "Email this to a friend"-img.
4. Drag down over it.
-> it scrolls far down, selecting all the text from where you clicked to where
the pointer is now.

Still happens with a 20030426ish cvs build.
OK, thanks.  With those steps, no problems reproducing.
Assignee: other → mjudge
Status: UNCONFIRMED → NEW
Component: Layout → Selection
Ever confirmed: true
QA Contact: ian → pmac

Comment 10

14 years ago
This is a dupe of bug 54538, which has been fixed lately.
Same issue: Bug 213840.

*** This bug has been marked as a duplicate of 54538 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.