Opening a draft email changes the 'From' address

RESOLVED DUPLICATE of bug 59548

Status

RESOLVED DUPLICATE of bug 59548
17 years ago
14 years ago

People

(Reporter: a1291762, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I have several accounts setup in Mail.

I was writing an email to someone and I had selected a different account
(Affects the From address and BCC's to somewhere). I saved the mail as a draft
and opened it later to continue. The mail had changed to use the 'default' (ie
first) account for the From. However the BCC was still there.


Reproducible: Always
Steps to Reproduce:
1. Make sure you have 2 accounts in Mail
2. Create an email and select the second account as the From
3. Save the email and close it
4. Open it again

Actual Results:  From changes to the first account.

Expected Results:  From should have stayed as it was put.

The From looks ok when you preview the email in the drafts folder so it's the
opening process that causes the problem.

Also, I have setup mail so that drafts and sent messages from all accounts get
stored in the drafts/sent folder of the first account (so they're all together).
Possibly Mail is reassigning the from to the first account because that's where
the mail is stored?

Comment 1

17 years ago
Confirming. Both my accounts are being set to save in Local Folders, which is in
neither IMAP share. When I open to edit as new, it uses my first account as the
from field.
(Mozilla 2002053012; testing on trunk build once I load it) WinXP+SP1

Comment 2

17 years ago
Confirming on build 2002071008 on windows XP+SP1

Updated

17 years ago
QA Contact: olgam → esther

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 59548 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.