Closed Bug 1568135 Opened 1 year ago Closed 1 year ago

OSX Mojave (10.14) - browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | Test timed out -

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1565738

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Filed by: egao [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=257832065&repo=try
Full log: https://queue.taskcluster.net/v1/task/LTMqRln0TDOgQi848cYeTQ/runs/0/artifacts/public/logs/live_backing.log


Platform: macosx1014
Suite: mochitest-bc

Context:
07:48:13 INFO - TEST-START | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js
07:48:13 INFO - GECKO(1785) | TEST DEVICES: No test devices found (in media.{audio,video}_loopback_dev, using fake streams.
07:48:58 INFO - TEST-INFO | started process screencapture
07:48:58 INFO - TEST-INFO | screencapture: exit 0
07:48:58 INFO - Buffered messages logged at 07:48:13
07:48:58 INFO - Entering test bound test
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | should start the test without any prior popup notification -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | should start the test with the control center hidden -
07:48:58 INFO - getUserMedia window/screen picking screen
07:48:58 INFO - requesting devices
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | webRTC-shareDevices notification shown -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | notification panel open -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | notification panel populated -
07:48:58 INFO - Buffered messages logged at 07:48:14
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | expected notification getUserMedia:request -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | anchored to device icon -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | microphone selector hidden -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | camera selector hidden -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | screen selector visible -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | panel using screen icon -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | There should be the 'Select Window or Screen' item, a separator and at least one window and one screen -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the 'Select Window or Screen' item is selected -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | 'Select Window or Screen' is the selected item -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | no window or screen is selected by default -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | 'Select Window or Screen' item is disabled -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | Allow button is disabled -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | Notification is marked as invalid -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the second item is a separator -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the 'all windows will be shared' warning should be hidden while there's no selection -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the preview area is hidden -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the window/screen item has the correct index -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the devicetype attribute is set correctly -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the window/screen item has the correct index -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the devicetype attribute is set correctly -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the window/screen item has the correct index -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the devicetype attribute is set correctly -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the screen item is marked as scary -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | there's at least one scary screen, as as all screens are -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the 'all windows will be shared' warning should now be visible -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the preview area is visible -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the scary warning is visible -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | Allow button is enabled -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the 'all windows will be shared' warning should now be hidden -
07:48:58 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | the preview area is hidden -
07:48:58 INFO - Buffered messages finished
07:48:58 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | Test timed out -
07:48:58 INFO - GECKO(1785) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
07:48:58 INFO - GECKO(1785) | MEMORY STAT | vsize 7778MB | residentFast 538MB | heapAllocated 181MB
07:48:58 INFO - TEST-OK | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | took 45160ms
07:48:58 INFO - Not taking screenshot here: see the one that was previously logged
07:48:58 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | Found a tab after previous test timed out: https://example.com/browser/browser/base/content/test/webrtc/get_user_media.html -
07:48:58 INFO - checking window state
07:48:58 INFO - GECKO(1785) | must wait for focus
07:48:58 INFO - GECKO(1785) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
07:48:58 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
07:55:08 INFO - Buffered messages finished
07:55:08 ERROR - TEST-UNEXPECTED-TIMEOUT | browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js (finished) | application timed out after 370 seconds with no output

See Also: → 1567656
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1565738
You need to log in before you can comment on or make changes to this bug.