Closed Bug 1568190 Opened 1 year ago Closed 1 year ago

7.28 - 8.35% raptor-tp6m-bing-geckoview-cold / raptor-tp6m-bing-geckoview-cold fcp / raptor-tp6m-bing-geckoview-cold loadtime (android-hw-g5-7-0-arm7-api-16) regression on push 84bdb98325f07ff5a2bfe2dd56e1906dab9889d2 (Wed July 10 2019)

Categories

(Core :: JavaScript: GC, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Bebe, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, regression)

== Change summary for alert #22077 (as of Tue, 23 Jul 2019 10:16:52 GMT) ==

Regressions:

8% raptor-tp6m-bing-geckoview-cold fcp android-hw-g5-7-0-arm7-api-16 opt 526.46 -> 570.42
8% raptor-tp6m-bing-geckoview-cold android-hw-g5-7-0-arm7-api-16 opt 463.28 -> 500.91
8% raptor-tp6m-bing-geckoview-cold loadtime android-hw-g5-7-0-arm7-api-16 opt 471.50 -> 506.96
7% raptor-tp6m-bing-geckoview-cold loadtime android-hw-g5-7-0-arm7-api-16 opt 470.04 -> 504.25

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=22077

Blocks: 1562138
Component: General → JavaScript: GC
Product: Testing → Core
Regressed by: 1564078
Version: Version 3 → unspecified

This blamed change (84bdb98325f07ff5a2bfe2dd56e1906dab9889d2) in bug 1564078 fixes functionality that was unintentionally removed by this change (same bug):

https://hg.mozilla.org/integration/mozilla-inbound/rev/1b3207f979714a183fba02476e292fd625b0beae

The priority flag is not set for this bug.
:jonco, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jcoppeard)

I'm going to close this as WONTFIX since the change in question fixes a regression (which could affect memory use). Looking at the graphs shows that these measures have improved since the start of June and even with this regression we're still better than where we started.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jcoppeard)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.