Closed Bug 1568252 Opened 1 year ago Closed 1 year ago

System downgrades to 68.0 after updating to 68.0.1 and shows "You've launched an older version of Firefox" dialog

Categories

(Toolkit :: Startup and Profile System, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: charles.roth, Unassigned)

Details

Attachments

(6 files)

Attached image profile-downgrade.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Automatic upgrade from 68.0 to 68.0.1 caused the "You've launched an older version" dialog box to appear. Appears to be the same issue as 1554029, but in 68 rather than 67.

Expected results:

Silent upgrade.

Apologies if I'm not submitting this correctly.

I commented on https://bugzilla.mozilla.org/show_bug.cgi?id=1554029 that this bug is happening "in the wild" in 68.0.1, but was told to submit a new bug.

Windows 10

And it just happened again. The dialog pops up when I started 68.0.1, somehow it thinks I'm on 68.0, kills my profile, then upgrades itself to 68.0.1. Something's really weird.

In firefox go to about:support and open your profile folder. In there is a compatibility.ini file, please attach it here.

Component: Untriaged → Startup and Profile System
Flags: needinfo?(charles.roth)
Product: Firefox → Toolkit

Done: the contents are:

[Compatibility]
LastVersion=68.0_20190705220548/20190705220548
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

Flags: needinfo?(charles.roth)

Ok, and what does it look like after the upgrade to 68.0.1?

Flags: needinfo?(charles.roth)

After the upgrade to 68.0.1 it looks like:

[Compatibility]
LastVersion=68.0.1_20190717172542/20190717172542
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

Flags: needinfo?(charles.roth)

I just tested out the upgrade on windows between those exact versions and didn't encounter the issue. It looks like you're using windows but the initial screenshot is from OSX, are you seeing it in both operating systems?

(In reply to charles.roth from comment #3)

And it just happened again. The dialog pops up when I started 68.0.1, somehow it thinks I'm on 68.0, kills my profile, then upgrades itself to 68.0.1. Something's really weird.

Can you clarify this statement? Why do you think it thinks you're on 68.0?

Flags: needinfo?(charles.roth)

Sorry, the screenshot was copied from the previous bug, not my laptop. But it was the same text.

Not sure what you mean by "why do you think it thinks you're on 68.0"? It said so! (Help /about.)

I'll try to replicate it (doesn't seem to have been hard, was happening every day for 4 days in a row) with complete screenshots.

Flags: needinfo?(charles.roth)

It does seem to "work" (stay in 68.0.1) for about a day, before it thinks it has reverted to 68.0. I'll try it again every day for the next several, and post the complete history here.

It sounds like something is actually downgrading you to 68.0. Which would certainly explain why the dialog is shown on startup when that happens. I can't think what that would be though.

OK, it happened again. Only about 4 hours after my previous attempt. Here are the steps as I recorded them.

  1. Earlier today, the help/about shows version 68.0.1 as shown in firefox-2019-07-25-01.png

  2. The about:support points me at p4d1zx99.default-release-4/compatibility.ini, which contains:
    [Compatibility]
    LastVersion=68.0.1_20190717172542/20190717172542
    LastOSABI=WINNT_x86_64-msvc
    LastPlatformDir=C:\Program Files\Mozilla Firefox
    LastAppDir=C:\Program Files\Mozilla Firefox\browser

  3. Roughly 4 hours later, when I started Firefox, I got the "old version" dialog box, as shown in firefox-2019-07-25-02.png.

  4. I clicked on "Create New Profile", then Tools/about, and it shows 68.0, and starts downloading the upgrade. (I tried to capture a screenshot, but lost the paste buffer. Dang.)

  5. I accepted the upgrade/restart.

  6. Now about:support points me (the newly created!) qsmu2c2z.default-release-5/compatbility.ini, which contains:
    [Compatibility]
    LastVersion=68.0.1_20190717172542/20190717172542
    LastOSABI=WINNT_x86_64-msvc
    LastPlatformDir=C:\Program Files\Mozilla Firefox
    LastAppDir=C:\Program Files\Mozilla Firefox\browser

I think I'm going to wait and try again tonight and tomorrow, and this time do a better job of capturing the help/about showing the 68.0 version, AND grab the compatibility.ini file it's pointing to BEFORE I accept the upgrade.

(In reply to charles.roth from comment #12)

OK, it happened again. Only about 4 hours after my previous attempt. Here are the steps as I recorded them.

  1. Earlier today, the help/about shows version 68.0.1 as shown in firefox-2019-07-25-01.png

  2. The about:support points me at p4d1zx99.default-release-4/compatibility.ini, which contains:
    [Compatibility]
    LastVersion=68.0.1_20190717172542/20190717172542
    LastOSABI=WINNT_x86_64-msvc
    LastPlatformDir=C:\Program Files\Mozilla Firefox
    LastAppDir=C:\Program Files\Mozilla Firefox\browser

  3. Roughly 4 hours later, when I started Firefox, I got the "old version" dialog box, as shown in firefox-2019-07-25-02.png.

  4. I clicked on "Create New Profile", then Tools/about, and it shows 68.0, and starts downloading the upgrade. (I tried to capture a screenshot, but lost the paste buffer. Dang.)

  5. I accepted the upgrade/restart.

  6. Now about:support points me (the newly created!) qsmu2c2z.default-release-5/compatbility.ini, which contains:
    [Compatibility]
    LastVersion=68.0.1_20190717172542/20190717172542
    LastOSABI=WINNT_x86_64-msvc
    LastPlatformDir=C:\Program Files\Mozilla Firefox
    LastAppDir=C:\Program Files\Mozilla Firefox\browser

I think I'm going to wait and try again tonight and tomorrow, and this time do a better job of capturing the help/about showing the 68.0 version, AND grab the compatibility.ini file it's pointing to BEFORE I accept the upgrade.

That would be useful. Additionally before the upgrade can you grab a copy of C:\ProgramData\Mozilla\updates\308046B0AF4A39CB\updates.xml

Will do, thanks!

There is code to prevents app update from downgrading to an earlier version as well as tests but perhaps it is failing in some fashion though the files should also be removed.

Could you take a look in C:\ProgramData\Mozilla\updates\ and post to this bug a list of the directories in that directory?

Flags: needinfo?(charles.roth)

Hello, i have the same issue on a Windows Server 2012R2 Terminalserver. 2 weeks ago a user got the older version of Firefox message and created a new profile, in the compatiblity.ini of the old profile is the following:
[Compatibility]
LastVersion=68.0_20190705220548/20190705220548
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

10 Days later he got the same message, compatiblity.ini of the old profile:
[Compatibility]
LastVersion=68.0.1_20190717172542/20190717172542
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

In the compatiblity.ini of new profile (current) is the same as in the last:
[Compatibility]
LastVersion=68.0.1_20190717172542/20190717172542
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

(In reply to s.rogl from comment #18)

Hello, i have the same issue on a Windows Server 2012R2 Terminalserver. 2 weeks ago a user got the older version of Firefox message and created a new profile, in the compatiblity.ini of the old profile is the following:
[Compatibility]
LastVersion=68.0_20190705220548/20190705220548
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

Was the user previously using Firefox 68.0.1?

Re: Robert Strong in comment #17, C:\ProgramData\Mozilla\updates\ contains 308046B0AF4A39CB.

I'm attaching the entire contents of that directory as a tar file, in case that helps any.

Flags: needinfo?(charles.roth)
Attached file updates.tar

This is the tar of the 308046B0AF4A39CB directory.

(In reply to charles.roth from comment #21)

Created attachment 9080903 [details]
updates.tar

This is the tar of the 308046B0AF4A39CB directory.

What was the state of Firefox when you made this?

Flags: needinfo?(charles.roth)

That's the 68.0.1 state. I'm waiting for the 'revert'(?) to 68.0 to repeat itself, at which point I'll dump everything that has been requested.

Flags: needinfo?(charles.roth)

OK, it happened again. It says I'm on version 68.0.

Prior to my hitting the "Create new profile" button, c/ProgramData/Mozilla/updates/308046B0AF4A39CB was EMPTY. That smells like a clue, given that it wasn't empty yesterday when I posted the previous comments (and the attached updates.tar file). Speculation: could there be something in there that a virus-checker might quarantine? I'll check on our end.

After "Create new profile", it contained one file, update-config.json:
{"app.update.auto":true}

about:support tells me that my profile folder is:
C:\Users\croth\AppData\Roaming\Mozilla\Firefox\Profiles\fm69uw85.default-release-6

and in that folder, compatibility.ini contains:
[Compatibility]
LastVersion=68.0_20190705220548/20190705220548
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\Program Files\Mozilla Firefox
LastAppDir=C:\Program Files\Mozilla Firefox\browser

I have (large) tarballs of the profiles directory, before and after, if they are useful. (Not posting because they're big.)

And... after a little bit, it automatically updated me to 68.0.1.

For the moment (since the above) I have turned OFF auto-update. But I'll happily try any experiments Mozilla folk suggest.

App update won't remove all of the contents of the c:\ProgramData\Mozilla\updates\308046B0AF4A39CB directory but the installer will. Could you attach the C:\Program Files\Mozilla Firefox\install.log file?

Requested C/Program Files/Mozilla Firefox/install.log file.

Attachment #9081033 - Attachment mime type: application/octet-stream → text/plain

The install log shows Firefox version 68.0 and has a date time of 2019-07-26 12:35:24.
Did you run a Firefox installer at that time?
If you didn't do you know of anything that might be running a Firefox installer at that time?

Flags: needinfo?(charles.roth)

I didn't run the installer... but auto-update was on, and I did have Firefox open around that time. (I think -- I'm on ET, is this UT or PT or ... ?)

Flags: needinfo?(charles.roth)

The install.log is only created by the installer and is never even touched by application update so having update on doesn't matter.

The time should be local time.

Something is running an installer on your system. Could you search your file system for files that start with "Firefox " (all of the installers should start with "Firefox ")?

Note: if there is other software running the installer and yes, there have been cases of other software not only doing this silently but also downloading the installer, it is possible that it has deleted the installer after it finished.

Summary:

  • The previous updates.xml shows an update to 68.0.1
  • The day after the update to 68.0.1 the updates directory contents were removed. App update doesn't remove the updates.xml and several other files as well as the sub-directories. The installer does remove all of these files and directories.
  • The day after the update to 68.0.1 the installer's log file (install.log) shows that an installation of Firefox 68.0 was performed based on its timestamp.
  • App update also has mechanisms which prevent updating to a previous version.

mhowell, could you help out with figuring out what is going on here?

Flags: needinfo?(mhowell)
Summary: Updating from 68.0 to 68.0.1 shows "You've launched an older version of Firefox" dialog → System downgrades to 68.0 after updating to 68.0.1 and shows "You've launched an older version of Firefox" dialog

I agree with comment 30. I think the evidence shows that something else on that machine must be running Firefox installers behind your back. It's clear that a 68.0 installer is running somehow, but you're not manually running it, and the update system won't do that automatically (it may ask you to download and run one manually, but only in failure cases that it doesn't sound like you're encountering).

Is this your personal computer, or is it under some kind of management by an IT organization at your company (or school, or other organization)? This sounds like the work of some intentionally configured software deployment system.

Flags: needinfo?(mhowell) → needinfo?(charles.roth)

Here's the list of everything on my drive that has a filename starting with "Firefox":
./ProgramData/Microsoft/Windows/Start Menu/Programs/Firefox.lnk
./Users/croth/AppData/Local/Mozilla/Firefox
./Users/croth/AppData/Roaming/Microsoft/Internet Explorer/Quick Launch/User Pinned/TaskBar/Firefox.lnk
./Users/croth/AppData/Roaming/Mozilla/Firefox
./Users/croth/Downloads/Firefox Installer.exe

I am removing the last file in the list, just in case.

I turned off auto-update, and the problem disappeared for 2 days. I turned it on again this morning, and within a few hours, the problem reappeared! So I'm guessing that whatever it is, it's obeying the auto-update setting.

Yes, this is a work laptop in a corporate setting (ProQuest.com), and the problem is happening to many other people in the company. That certainly smells like something our IT dept is doing (however accidentally/unintentionally), and I am actively pursuing that with them.

Flags: needinfo?(charles.roth)

So right now when I start Firefox, I get the "You've launched an older version..." dialog.

W/o accepting the "create new profile", I went and looked in c/Users/croth/appdata/Roaming/Mozilla/Firefox/Profiles, and I see the the profile directory fm69uw85.default-release-6 was last modified at 11:31 this morning.

I poked around in that directory, and found everything that was modified at that time, and have attached it as a tarball below.

If I'm at the point where I'm wasting your time, let me know. And I'm definitely pursuing this with our IT group. But if you find any clues in that attachment, I'd obviously love to know. Many thanks for you attention to this little saga.

Attached file ff1131.tar

Files changed in Firefox profile at 11:31, apparently when the 'downgrade' happened.

Is your company managing your Firefox? It sounds like your IT department might be pushing an older version?

Looking more and more likely that this was caused by an automatic deployment by IT at our end.

Many thanks for your help in looking into this. Recommendations for how we should send more 'concrete' thanks are welcome.

I'm resolving this as "invalid", hope that's correct.

Looking more and more likely that this was caused by an automatic deployment by IT at our end.

Many thanks for your help in looking into this. Recommendations for how we should send more 'concrete' thanks are welcome.

I'm resolving this as "invalid", hope that's correct.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

Feel free to send your IT department my way if they have any questions about turning off local updates so they can do the updating. We have lots of new policies they can use.

You need to log in before you can comment on or make changes to this bug.