Closed Bug 1568393 Opened 1 year ago Closed 1 year ago

Intermittent GECKO(620) | Assertion failure: mPresContext->mLayoutPhaseCount[nsLayoutPhase::FrameC] == 0 (painting in the middle of frame construction), at z:/build/build/src/layout/base/nsAutoLayoutPhase.cpp:38

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1438939

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=258005436&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/Wz4GYdd0SJ-RWqP2Kf8OEQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-07-24T01:34:30.948Z] 01:34:30 INFO - TEST-START | dom/tests/browser/browser_unlinkable_about_page_can_load_module_scripts.js
[task 2019-07-24T01:34:30.950Z] 01:34:30 INFO - GECKO(620) | Chrome file doesn't exist: Z:\task_1563928366\build\tests\mochitest\browser\dom\tests\browser\head.js
[task 2019-07-24T01:34:31.000Z] 01:34:31 INFO - GECKO(620) | ++DOCSHELL 00000238D1D83000 == 2 [pid = 7344] [id = {cd771542-83f6-4843-be3c-a4a07b5395a9}]
[task 2019-07-24T01:34:31.000Z] 01:34:31 INFO - GECKO(620) | ++DOMWINDOW == 3 (00000238D1D19880) [pid = 7344] [serial = 37] [outer = 0000000000000000]
[task 2019-07-24T01:34:31.005Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: No active window: file z:/build/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
[task 2019-07-24T01:34:31.005Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: No active window: file z:/build/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
[task 2019-07-24T01:34:31.015Z] 01:34:31 INFO - GECKO(620) | [Parent 6716, Main Thread] WARNING: Constructing RangeBoundary with invalid value: 'mRef || aOffset == 0', file z:/build/build/src/obj-firefox/dist/include\mozilla/RangeBoundary.h, line 79
[task 2019-07-24T01:34:31.015Z] 01:34:31 INFO - GECKO(620) | [Parent 6716, Main Thread] WARNING: Constructing RangeBoundary with invalid value: 'mRef || aOffset == 0', file z:/build/build/src/obj-firefox/dist/include\mozilla/RangeBoundary.h, line 79
[task 2019-07-24T01:34:31.020Z] 01:34:31 INFO - GECKO(620) | ++DOMWINDOW == 4 (00000238D0F9C800) [pid = 7344] [serial = 38] [outer = 00000238D1D19880]
[task 2019-07-24T01:34:31.042Z] 01:34:31 INFO - GECKO(620) | ++DOMWINDOW == 5 (00000238D3F29800) [pid = 7344] [serial = 39] [outer = 00000238D1D19880]
[task 2019-07-24T01:34:31.052Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(mStatus, *this) failed with result 0x80004005: file z:/build/build/src/obj-firefox/dist/include\nsIURIMutator.h, line 489
[task 2019-07-24T01:34:31.052Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/netwerk/protocol/http/nsCORSListenerProxy.cpp, line 925
[task 2019-07-24T01:34:31.054Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/dom/security/nsContentSecurityManager.cpp, line 435
[task 2019-07-24T01:34:31.054Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/dom/security/nsContentSecurityManager.cpp, line 963
[task 2019-07-24T01:34:31.056Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/dom/script/ScriptLoader.cpp, line 1460
[task 2019-07-24T01:34:31.056Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/netwerk/protocol/http/nsCORSListenerProxy.cpp, line 925
[task 2019-07-24T01:34:31.059Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/dom/security/nsContentSecurityManager.cpp, line 435
[task 2019-07-24T01:34:31.059Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/dom/security/nsContentSecurityManager.cpp, line 963
[task 2019-07-24T01:34:31.060Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805303F4: file z:/build/build/src/dom/script/ScriptLoader.cpp, line 1460
[task 2019-07-24T01:34:31.332Z] 01:34:31 INFO - GECKO(620) | [Parent 6716, Main Thread] WARNING: Constructing RangeBoundary with invalid value: 'mRef || aOffset == 0', file z:/build/build/src/obj-firefox/dist/include\mozilla/RangeBoundary.h, line 79
[task 2019-07-24T01:34:31.332Z] 01:34:31 INFO - GECKO(620) | [Parent 6716, Main Thread] WARNING: Constructing RangeBoundary with invalid value: 'mRef || aOffset == 0', file z:/build/build/src/obj-firefox/dist/include\mozilla/RangeBoundary.h, line 79
[task 2019-07-24T01:34:31.342Z] 01:34:31 INFO - GECKO(620) | [Child 1460, Main Thread] WARNING: No active window: file z:/build/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
[task 2019-07-24T01:34:31.361Z] 01:34:31 INFO - GECKO(620) | ++DOCSHELL 00000238D3190800 == 3 [pid = 7344] [id = {059575c4-af00-41ba-b935-d6a5a1be06bf}]
[task 2019-07-24T01:34:31.361Z] 01:34:31 INFO - GECKO(620) | ++DOMWINDOW == 6 (00000238D4579B60) [pid = 7344] [serial = 40] [outer = 0000000000000000]
[task 2019-07-24T01:34:31.380Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: No active window: file z:/build/build/src/js/xpconnect/s[Parent 6716, Mainrc/XPCJSContext.cpp, line 662
[task 2019-07-24T01:34:31.380Z] 01:34:31 INFO - GECKO(620) | Thread] WARNING: Constructing RangeBoundary with invalid value: 'mRef || aOffset == 0', file z:/build/build/src/obj-firefox/dist/include\mozilla/RangeBoundary.h, line 79
[task 2019-07-24T01:34:31.380Z] 01:34:31 INFO - GECKO(620) | [Parent 6716, Main Thread] WARNING: Constructing RangeBoundary with invalid value: 'mRef || aOffset == 0', file z:/build/build/src/obj-firefox/dist/include\mozilla/RangeBoundary.h, line 79
[task 2019-07-24T01:34:31.380Z] 01:34:31 INFO - GECKO(620) | ++DOMWINDOW == 7 (00000238D316F400) [pid = 7344] [serial = 41] [outer = 00000238D4579B60]
[task 2019-07-24T01:34:31.399Z] 01:34:31 INFO - GECKO(620) | ++DOMWINDOW == 8 (00000238D3FDA400) [pid = 7344] [serial = 42] [outer = 00000238D4579B60]
[task 2019-07-24T01:34:31.401Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: NS_ENSURE_SUCCESS(mStatus, *this) failed with result 0x80004005: file z:/build/build/src/obj-firefox/dist/include\nsIURIMutator.h, line 489
[task 2019-07-24T01:34:31.411Z] 01:34:31 INFO - GECKO(620) | [Child 7344, Main Thread] WARNING: No active window: file z:/build/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
[task 2019-07-24T01:34:31.411Z] 01:34:31 INFO - GECKO(620) | Assertion failure: mPresContext->mLayoutPhaseCount[nsLayoutPhase::FrameC] == 0 (painting in the middle of frame construction), at z:/build/build/src/layout/base/nsAutoLayoutPhase.cpp:38
[task 2019-07-24T01:34:31.530Z] 01:34:31 INFO - GECKO(620) | #01: mozilla::PresShell::Paint(nsView *,nsRegion const &,mozilla::PaintFlags) [layout/base/PresShell.cpp:6033]
[task 2019-07-24T01:34:31.530Z] 01:34:31 INFO -
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO - GECKO(620) | #02: mozilla::dom::BrowserChild::MakeVisible(bool) [dom/ipc/BrowserChild.cpp:2789]
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO -
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO - GECKO(620) | #03: mozilla::dom::BrowserChild::RecvRenderLayers(bool const &,bool const &,mozilla::layers::LayersObserverEpoch const &) [dom/ipc/BrowserChild.cpp:0]
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO -
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO - GECKO(620) | #04: mozilla::dom::BrowserChild::PaintWhileInterruptingJS(mozilla::layers::LayersObserverEpoch const &,bool) [dom/ipc/BrowserChild.cpp:3340]
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO -
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO - GECKO(620) | #05: static bool InterruptCallback(struct JSContext *) [dom/ipc/ProcessHangMonitor.cpp:1216]
[task 2019-07-24T01:34:31.531Z] 01:34:31 INFO -
[task 2019-07-24T01:34:31.532Z] 01:34:31 INFO - GECKO(620) | #06: JSContext::handleInterrupt() [js/src/vm/Runtime.cpp:510]

Same cause as bug 1438939.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1438939
You need to log in before you can comment on or make changes to this bug.