Closed Bug 15685 Opened 20 years ago Closed 20 years ago

[DOGFOOD] Regression: Copy and Folder settings combo box does not display folders in popup

Categories

(SeaMonkey :: MailNews: Account Configuration, defect, P2, major)

All
Other

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: fenella, Assigned: alecf)

References

Details

Linux (1999-10-06-08-M11)
win32 (1999-10-06-09-M11)
Mac (1999-10-06-08-M11)
Summery: Regression-Copy and Folder settings drop-down menu does not display
sub-menus
Steps:
1. From Messenger, select Edit|Account Settings
2. From the Account Setings window, double click on the account name,eg qatest38
on nsmail-5
3. Click on Copies and Folders to display the Copy and folder settings options
4. Click on any of the downward arrows to display the drop-down submenus

Actual results: None of them display its sub-menus
Expected results: It used to have sub-menus so that I can select to place a copy
in the Sent folder.

This occurs in all three platforms.
Status: NEW → ASSIGNED
I think pav just fixed this...checking now.
Summary: Regression: Copy and Folder settings drop-down menu does not display submenus → Regression: Copy and Folder settings combo box does not display folders in popup
Nope, pav fixed a menu bug, this bug is for combo boxes.

Fenella, these widgets are called "combo boxes" not "menus" and the little list
of options in a combo box is just called the combo box's "list" or "popup" or
"dropdown" but it is also not a "menu"

.. it is very confusing when call them menus.

The problem here is that the template in the combo box is not filling in option
from RDF.

I haven't had a chance to try this with today's build, but adding waterson
anyway, since he recently revved the XUL content model builder...
Severity: normal → major
Priority: P3 → P2
Target Milestone: M11
alecf: what's the XUL file?
Blocks: 12149
whoops..
chrome://messenger/content/am-copies.xul (the panel in question)
chrome://messenger/content/AccountManager.xul (the dialog containing the panel)

I opened this with the DOM viewer, and it looks like the template is basically
ignored now...the content inside the select widget was just the template itself.
Blocks: 15874
*** Bug 16517 has been marked as a duplicate of this bug. ***
alecf: any progress on this? do you want to take a look at this together on
monday?
I've just been distracted with other work, I haven't actually made any progress
here :) Let me try this again on monday morning and then we can get together
monday or tuesday
Summary: Regression: Copy and Folder settings combo box does not display folders in popup → [DOGFOOD] Regression: Copy and Folder settings combo box does not display folders in popup
Nominate for dogfood
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
ok, I have fixed these widgets so that they show the right folders
(turned out to be a slight change in namespaces for the datasources attribute)

Unfortunately for linux and mac, the select combo box is still broken in modal
dialogs.
Status: RESOLVED → REOPENED
Win32 (1999-10-19-09-M11)
The Copy and Folder settings combo box now displays folders in popup.
Other Combo boxes do not display
But for Linux and Mac's does not. The Combo boxes are NOT enabled.
Sorry I have to re-open it pending Linux and Mac fixes.
Resolution: FIXED → ---
Fenella, the Mac and Linux combo boxes not working are the subject of another
bug. When that bug is fixed, then the Copy and Folder settings combo box should
work fine.

I assume that Win32 works well for you now.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
actually do you know where that bug is? I've been searching for it for 2 days, I
think I even added a comment at one point
http://bugzilla.mozilla.org/show_bug.cgi?id=15476 (ask me next time and I'll
find the bug for you :-)
heh, thanks!
Win32 works fine. Will check Linux and Mac when bug  15476 is fixed.
Whiteboard: [PDT-]
Sent folder at top level is default; sent folder not at the top is not dogfood.
Whiteboard: [PDT-]
no this says that a large part of the UI is broken. This has already been fixed,
why bother marking it PDT-?

Removing PDT-.
Blocks: 16950
Status: RESOLVED → VERIFIED
Using 19991028 builds on win98, mac and linux drop down list for Copies and
Folders not listing folders correctly when sub folders are involved.  When there
are sub folders in a mail account the folder which has the sub folder is listed
as if it were an account with other top level folders listed under them.  This
bug stated the sub folders were not listed, they are now listed but with the
problem above.  I will verify this one and log a new bug for the wrong order.
New bug logged for wrong order 17570.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.