Recursive frameset crashes in various different ways

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
critical
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Stephane Moureau, Assigned: saari (gone))

Tracking

({crash})

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
That intentional javascript crash page (frameset loop) reacts very differently in Chimera 
(build 20020710 16:11).

Sometimes, it crash after it has draw 4 cells, see crash log.

Sometimes, its contents is drawn entierly (~20x20 cells) immediately after you've seen 
the 4 cells.
You get a grid, but the 'cells' are bigger than those obtained in M$IE 5.21.

IE draws them one by one, you see all the process until it crash when the status bar show 
the link ...?11 at that stage the cell are very very small, chimera has cells 2 or 3 times 
bigger than IE (? 8 -> 11).
Chimera becomes very slow, probably huge ram comsuption and seems to stay stable 
and is still working.

Sometimes, it stop saying that it can't reach the link ...?8 and an alert sheet don't stop 
appearing, you can't quit, stop, you must force quit.
The console in that case says:
2002-07-11 12:55:33.625 Navigator[957] *** WARNING: Method 
runModalForWindow:relativeToWindow: in class NSApplication is obsolete and will be 
removed in release GM ***

What's strange is that it was accessible few seconds before.

In Chimera during that slow drawing, you see in the Status bar that say ~'Read user file 
in the chimera profile'.
(Reporter)

Comment 1

16 years ago
Created attachment 90942 [details]
js2-crash log

js2-crash log

Comment 2

16 years ago
*** Bug 156869 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Stephane, what Chimera build are you using? Always be sure to include your build
information in bug reports.
Severity: normal → critical
Keywords: crash

Comment 4

16 years ago
Also, Stephane, did you test this in Mozilla? What were the results?
(Reporter)

Comment 5

16 years ago
What's going on...
the build is on the first line and the attach is there too ?

Comment 6

16 years ago
Whoops, sorry Stephane. I don't know how I missed that.

Comment 7

16 years ago
using Chimera/20020708, the tescase runs for a time then an error sheet bearing
the text, "The file /crash/js2.html?8 cannot be found. Please check the location
and try again" is repeatedly shown, eventually also crashing at js_AllocGCThing.

Comment 8

16 years ago
Created attachment 91226 [details]
Crash report generated by Chimera/20020708 showing crash at js_AllocGCThing

Comment 9

16 years ago
...but, WorksForMe using FizzillaCFM/2002071208.
Summary: Crash test weird reactions: ok, crash or block and force quit → Crash test weird reactions: ok, crash or block and force quit [@ js_AllocGCThing]

Updated

16 years ago
Summary: Crash test weird reactions: ok, crash or block and force quit [@ js_AllocGCThing] → Recursive frameset crashes in various different ways

Comment 10

15 years ago
WFM Camino 2003061704... my guess is this got picked up in the move to the truck
if it was ok in mozilla proper in the last set of comments.

anyone argue with a resolution of WFM here?

Comment 11

15 years ago
well ok then... since noone objected -> WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.