Open Bug 1568717 Opened 4 months ago Updated 2 months ago

Intermittent TEST-UNEXPECTED-PASS | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | Https downgrade prefetch => No headers - expected FAIL

Categories

(Core :: DOM: Networking, defect, P5)

defect

Tracking

()

REOPENED
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: apavel)

References

(Regression)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [retriggered][necko-triaged])

Attachments

(2 files, 1 obsolete file)

Filed by: dvarga [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=258216868&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/Edpjir0mT-2BvTbt58SpAg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-07-25T01:19:40.004Z] 01:19:40     INFO - TEST-PASS | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | Https downgrade object => No headers 
[task 2019-07-25T01:19:40.004Z] 01:19:40     INFO - TEST-UNEXPECTED-PASS | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | Https downgrade prefetch => No headers - expected FAIL
[task 2019-07-25T01:19:40.005Z] 01:19:40     INFO - TEST-INFO | expected FAIL
[task 2019-07-25T01:19:40.005Z] 01:19:40     INFO - ......
[task 2019-07-25T01:19:40.005Z] 01:19:40     INFO - TEST-TIMEOUT | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | took 10233ms
[task 2019-07-25T01:19:40.020Z] 01:19:40     INFO - PID 2104 | [Child 4632, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_ch1564017580007	Marionette	INFO	Stopped listening on port 49406
[task 2019-07-25T01:19:40.095Z] 01:19:40     INFO - PID 2104 | [Parent 4596, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.096Z] 01:19:40     INFO - PID 2104 | [Child 4496, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.112Z] 01:19:40     INFO - PID 2104 | [Child 4496, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channe[Child 4540, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.113Z] 01:19:40     INFO - PID 2104 | [Child 5532, Chro[Child 4540, Chrome_ChildThread] WARNING: me_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.128Z] 01:19:40     INFO - PID 2104 | [Child 5532, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/co[Parent 4596, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.128Z] 01:19:40     INFO - PID 2104 | [Child 3592, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.128Z] 01:19:40     INFO - PID 2104 | [Child 3592, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.128Z] 01:19:40     INFO - PID 2104 | [Parent 4596, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.129Z] 01:19:40     INFO - PID 2104 | [Child 2704, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1564007595/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
[task 2019-07-25T01:19:40.596Z] 01:19:40     INFO - PID 2104 | [Child 2704, Chrome_ChildThread] WARNING: p
[task 2019-07-25T01:19:40.617Z] 01:19:40     INFO - Browser exited with return code 0
[task 2019-07-25T01:19:40.617Z] 01:19:40     INFO - PROCESS LEAKS None
[task 2019-07-25T01:19:40.618Z] 01:19:40     INFO - Closing logging queue
[task 2019-07-25T01:19:40.619Z] 01:19:40     INFO - queue closed
[task 2019-07-25T01:19:40.634Z] 01:19:40     INFO - Setting up ssl
[task 2019-07-25T01:19:40.689Z] 01:19:40     INFO - certutil | 
[task 2019-07-25T01:19:40.736Z] 01:19:40     INFO - certutil | 
[task 2019-07-25T01:19:40.756Z] 01:19:40     INFO - certutil | 
[task 2019-07-25T01:19:40.756Z] 01:19:40     INFO - Certificate Nickname                                         Trust Attributes
[task 2019-07-25T01:19:40.756Z] 01:19:40     INFO -                                                              SSL,S/MIME,JAR/XPI
Whiteboard: [test isolation]
Whiteboard: [test isolation]
Whiteboard: [retriggered]
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/927abd2c418b
update redirect-https-downgrade.tentative.sub.html expectations r=jgraham
Whiteboard: [retriggered] → [retriggered][necko-triaged]
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → apavel
Flags: needinfo?(james)

Ugh, I think this hit the bug in the metadata update that nikkis is looking at where we sometimes overwrite intermittents in the metadata when we get a consistent result in a try push and do a full update. Just need to revert that change.

Flags: needinfo?(james)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla70 → ---

No occurrences since August 1st.

See Also: → 1570643
Attachment #9083413 - Attachment description: Bug 1568717 - Disabled redirect-https-downgrade.tentative.sub.html on Windows and Linux for high failure rate. r=jmaher → Bug 1568717 - Disabled redirect-https-downgrade.tentative.sub.html on Windows and Linux for high failure rate. r=jgraham
Attachment #9083413 - Attachment description: Bug 1568717 - Disabled redirect-https-downgrade.tentative.sub.html on Windows and Linux for high failure rate. r=jgraham → Bug 1568717 - Update test expectation on win, linux and mac cause of frequent failures. r=jgraham
Keywords: leave-open
Attachment #9083413 - Attachment is obsolete: true
Whiteboard: [retriggered][necko-triaged][stockwell disable-recommended] → [retriggered][necko-triaged]
See Also: → 1569098
Attachment #9084593 - Attachment description: Bug 1568717 - update redirect-https-downgrade.tentative.sub.html expectations on mac, windows and linux. r=jgraham → Bug 1568717 - update redirect-https-downgrade.tentative.sub.html expectations after wpt-sync rise in failures. r=jgraham

Also, James, could we merge all these three bugs into one https://bugzilla.mozilla.org/buglist.cgi?short_desc_type=allwordssubstr&short_desc=redirect-https-downgrade.tentative.sub.html%20%7C%20Https%20downgrade%20prefetch&query_format=advanced&list_id=14846297 and follow all the fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html failures in this one?

Flags: needinfo?(james)
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6ca3d7e647b
update redirect-https-downgrade.tentative.sub.html expectations after wpt-sync rise in failures. r=jgraham
Whiteboard: [retriggered][necko-triaged][stockwell disable-recommended] → [retriggered][necko-triaged]
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea12b83e1ce4
Add missing ")" to the syntax. r=wpt-fix
See Also: → 1568817
Flags: needinfo?(james)

Merging the bugs looks fine to me.

Duplicate of this bug: 1568817
Duplicate of this bug: 1569098

Failures should go down from comment 25.

Whiteboard: [retriggered][necko-triaged][stockwell disable-recommended] → [retriggered][necko-triaged]
Whiteboard: [retriggered][necko-triaged][stockwell disable-recommended] → [retriggered][necko-triaged]
Depends on: 1574881
Component: DOM: Networking → DOM: Security
Whiteboard: [retriggered][necko-triaged] → [retriggered]

We don't yet implement sec-metadata. Any failures are just fetch things in networking

Component: DOM: Security → DOM: Networking
Whiteboard: [retriggered] → [retriggered][necko-triaged]

Most of the recent occurrences here are failures and 2/3 of them unexpected passes.

This regressed when wptsync landed with Bug 1576813

Regressed by: 1576813
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb209ce9e3df
Update test expectations cause of recent failures. a=test-only
You need to log in before you can comment on or make changes to this bug.