Closed Bug 1568747 Opened 2 years ago Closed 2 years ago

Massive Mozmill failure on 2019-07-25 - Write window broken - Port bug 1550801 - Load XUL documents as XHTML documents

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 70.0

People

(Reporter: jorgk-bmo, Assigned: darktrojan)

Details

Attachments

(1 file)

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1da5a37de0fd1695e96a9d5e7f59fbd84d8759b2&tochange=922be4adb708aee5ab59602b38fbb19f37c2de53

I haven't looked, but it could be
fd2b93ff0abecc11bcfbcd806262c79f5de50b9b Brendan Dahl — Bug 1550801 - Load XUL documents as XHTML documents. r=smaug

That would be something for our sadly not so pro-active de-XBL team. Geoff, have you looked?

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)

That try is looking good, sadly you don't have a patch but rather a backout :-(
+GECKO_HEAD_REPOSITORY: https://hg.mozilla.org/try
+GECKO_HEAD_REF: ab6d3e5e6d1ad4b4744cd1234983ced7172359ec

https://hg.mozilla.org/try/graph/ab6d3e5e6d1ad4b4744cd1234983ced7172359ec

which has
Backed out changeset fd2b93ff0abe (bug 1550801)

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Summary: Massive (or total?) Mozmill failure on 2019-07-25 → Massive (or total?) Mozmill failure on 2019-07-25 - Port bug 1550801 - Load XUL documents as XHTML documents

Looks like our composition window is broken, so all related tests fail, of course. There are also test failures in mail account setup and heaps of Calendar failures.

Looks like I'll cancel Dailies for a while.

Summary: Massive (or total?) Mozmill failure on 2019-07-25 - Port bug 1550801 - Load XUL documents as XHTML documents → Massive Mozmill failure on 2019-07-25 - Write window broken - Port bug 1550801 - Load XUL documents as XHTML documents

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/71dbc5c422f8
No bug - Disable Nightly builds . a=jorgk CLOSED TREE

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Keywords: leave-open
Backout by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1177eb495b94
Backed out changeset 71dbc5c422f8 since it not only breaks shippable/daily/nightly builds. a=backout CLOSED TREE
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/33aa95186ee7
Fix overlay loader for HTML documents and stop waiting for menulist CE; rs=bustage-fix CLOSED TREE

That should fix most stuff, if not all. My Try run is greener than I expected.

Thx, Geoff!

Assignee: mkmelin+mozilla → geoff
Flags: needinfo?(mkmelin+mozilla)

Can someone review the landed patch? Is this the final solution? Not being able to wait for "menulist" seems to need a follow-up:

10:18:28 - darktrojan: oh cool, so one of the things you can't do as an xhtml document is wait for custom elements without a hyphen in the name
10:18:40 - darktrojan: like menulist
10:18:43 - darktrojan: :/

Custom elements are required to have a dash in their name. That it hasn't been enforced was by design, but nevertheless a non standard feature.

So why are there custom elements without a hyphen which are bound to break?

Please note the difference between dash and hyphen:
https://www.ef.com/wwen/english-resources/english-grammar/hyphens-and-dashes/

AFAIK they were/are only allowed (internally?) to cause minimum change requirements during the de-xbl conversion. I'd expect that at some point this allowance will go away, and we've therefore proactively renamed some elements (like minimonth) to something with a hypen instead.

Attachment #9081515 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9081515 [details] [diff] [review]
1568747-xul-html-bustage.diff

Review of attachment 9081515 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #9081515 - Flags: review?(mkmelin+mozilla) → review+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0
You need to log in before you can comment on or make changes to this bug.