Closed Bug 1568817 Opened 4 months ago Closed 4 months ago

Intermittent /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | Https downgrade prefetch => No headers - assert_not_equals: got disallowed value "No header has been recorded"

Categories

(Core :: DOM: Networking, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1568717

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [necko-triaged][stockwell disable-recommended])

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=258249704&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/RxJNSuryQseulazbzTl_Gg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-07-25T07:14:05.029Z] 07:14:05 INFO - TEST-PASS | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | Https downgrade object => No headers
[task 2019-07-25T07:14:05.029Z] 07:14:05 INFO - TEST-UNEXPECTED-FAIL | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | Https downgrade prefetch => No headers - assert_not_equals: got disallowed value "No header has been recorded"
[task 2019-07-25T07:14:05.029Z] 07:14:05 INFO - assert_header_equals@http://web-platform.test:8000/fetch/sec-metadata/resources/helper.js:7:5
[task 2019-07-25T07:14:05.029Z] 07:14:05 INFO - RunCommonRedirectTests/</e.onload</<@http://web-platform.test:8000/fetch/sec-metadata/resources/redirectTestHelper.sub.js:122:42
[task 2019-07-25T07:14:05.029Z] 07:14:05 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-07-25T07:14:05.029Z] 07:14:05 INFO - Test.prototype.step_func_done/<@http://web-platform.test:8000/resources/testharness.js:1651:32
[task 2019-07-25T07:14:05.238Z] 07:14:05 INFO - ......
[task 2019-07-25T07:14:05.238Z] 07:14:05 INFO - TEST-TIMEOUT | /fetch/sec-metadata/redirect/redirect-https-downgrade.tentative.sub.html | took 30582ms
[task 2019-07-25T07:14:05.877Z] 07:14:05 INFO - Closing logging queue
[task 2019-07-25T07:14:05.878Z] 07:14:05 INFO - queue closed
[task 2019-07-25T07:14:05.893Z] 07:14:05 INFO - Setting up ssl
[task 2019-07-25T07:14:05.909Z] 07:14:05 INFO - certutil |
[task 2019-07-25T07:14:05.929Z] 07:14:05 INFO - certutil |
[task 2019-07-25T07:14:05.945Z] 07:14:05 INFO - certutil |
[task 2019-07-25T07:14:05.945Z] 07:14:05 INFO - Certificate Nickname Trust Attributes
[task 2019-07-25T07:14:05.945Z] 07:14:05 INFO - SSL,S/MIME,JAR/XPI
[task 2019-07-25T07:14:05.945Z] 07:14:05 INFO -
[task 2019-07-25T07:14:05.945Z] 07:14:05 INFO - web-platform-tests CT,,
[task 2019-07-25T07:14:05.945Z] 07:14:05 INFO -
[task 2019-07-25T07:14:07.563Z] 07:14:07 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-07-25T07:14:08.809Z] 07:14:08 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_CRASHREPORTER_NO_REPORT=1 --es env8 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 MOZ_HIDE_RESULTS_TABLE=1 --es env2 R_LOG_VERBOSE=1 --es env1 MOZ_WEBRENDER=0 --es env0 MOZ_CRASHREPORTER=1 --es env7 R_LOG_DESTINATION=stderr --es env6 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env5 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env4 STYLO_THREADS=4 --ez use_multiprocess True --es env11 R_LOG_LEVEL=6 --es env10 MOZ_PROCESS_LOG=/tmp/tmpx4_5m7pidlog
[task 2019-07-25T07:14:10.393Z] 07:14:10 INFO - Starting runner

Regressed by: 1567435

This is new wpt and we need some web-compat implementation first before the intermittent.
Will become higher priority once it still happen after we have bug 1559996.

Depends on: 1559996
Priority: P5 → P3
Whiteboard: [necko-triaged]

There are 57 failures associated to this bug in the last 7 days. These are occurring mostly on android-em-7-0-x86_64 and some on linux64 debug and macosx1014-64-shippable opt.

The failures here should be included in the changes in Bug 1572693 (updates on Android) and with the patch in Bug 1568717 https://phabricator.services.mozilla.com/D41498

See Also: → 1568717
Whiteboard: [necko-triaged][stockwell disable-recommended] → [necko-triaged]

will track these failures in bug 1568717

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1568717
You need to log in before you can comment on or make changes to this bug.