Closed Bug 1568835 Opened 4 months ago Closed 4 months ago

Permafail TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html | when Gecko 70 merges to Beta on 2019-08-26

Categories

(Core :: Web Audio, defect, P5)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: intermittent-bug-filer, Assigned: CosminS)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=258278580&repo=try
Full log: https://queue.taskcluster.net/v1/task/EgLdWo6kQL6zRy2gEC1KLQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-07-25T12:16:49.137Z] 12:16:49 INFO - TEST-START | /webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html
[task 2019-07-25T12:16:49.194Z] 12:16:49 INFO - Setting pref privacy.reduceTimerPrecision (false)
[task 2019-07-25T12:16:50.396Z] 12:16:50 INFO - PID 25911 | JavaScript error: https://web-platform.test:8443/webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html, line 52: TypeError: realtimeContext.audioWorklet is undefined
[task 2019-07-25T12:16:50.445Z] 12:16:50 INFO -
[task 2019-07-25T12:16:50.445Z] 12:16:50 INFO - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html |
[task 2019-07-25T12:16:50.445Z] 12:16:50 INFO - Test the invocation order of AudioWorklet.addModule() and BaseAudioContext
[task 2019-07-25T12:16:50.445Z] 12:16:50 INFO - - TypeError: realtimeContext.audioWorklet is undefined
[task 2019-07-25T12:16:50.445Z] 12:16:50 INFO - @https://web-platform.test:8443/webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html:52:11
[task 2019-07-25T12:16:50.445Z] 12:16:50 INFO - TEST-OK | /webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html | took 1311ms
[task 2019-07-25T12:16:50.466Z] 12:16:50 INFO - PID 25911 | 1564057010459 Marionette INFO Stopped listening on port 49733
[task 2019-07-25T12:16:50.648Z] 12:16:50 INFO - PID 25911 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-07-25T12:16:50.655Z] 12:16:50 INFO - PID 25911 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-07-25T12:16:50.691Z] 12:16:50 INFO - PID 25911 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-07-25T12:16:51.434Z] 12:16:51 INFO - PID 25911 | -----------------------------------------------------
[task 2019-07-25T12:16:51.434Z] 12:16:51 INFO - PID 25911 | Suppressions used:
[task 2019-07-25T12:16:51.435Z] 12:16:51 INFO - PID 25911 | count bytes template
[task 2019-07-25T12:16:51.435Z] 12:16:51 INFO - PID 25911 | 26 800 nsComponentManagerImpl
[task 2019-07-25T12:16:51.435Z] 12:16:51 INFO - PID 25911 | 2 288 libfontconfig.so
[task 2019-07-25T12:16:51.435Z] 12:16:51 INFO - PID 25911 | -----------------------------------------------------
[task 2019-07-25T12:16:51.476Z] 12:16:51 INFO - PID 25911 | -----------------------------------------------------
[task 2019-07-25T12:16:51.476Z] 12:16:51 INFO - PID 25911 | Suppressions used:
[task 2019-07-25T12:16:51.477Z] 12:16:51 INFO - PID 25911 | count bytes template
[task 2019-07-25T12:16:51.477Z] 12:16:51 INFO - PID 25911 | 26 800 nsComponentManagerImpl
[task 2019-07-25T12:16:51.477Z] 12:16:51 INFO - PID 25911 | 611 17713 libfontconfig.so
[task 2019-07-25T12:16:51.477Z] 12:16:51 INFO - PID 25911 | 1 29 libglib-2.0.so
[task 2019-07-25T12:16:51.477Z] 12:16:51 INFO - PID 25911 | -----------------------------------------------------
[task 2019-07-25T12:16:51.574Z] 12:16:51 INFO - PID 25911 | -----------------------------------------------------
[task 2019-07-25T12:16:51.574Z] 12:16:51 INFO - PID 25911 | Suppressions used:
[task 2019-07-25T12:16:51.575Z] 12:16:51 INFO - PID 25911 | count bytes template
[task 2019-07-25T12:16:51.575Z] 12:16:51 INFO - PID 25911 | 26 800 nsComponentManagerImpl
[task 2019-07-25T12:16:51.575Z] 12:16:51 INFO - PID 25911 | 611 17713 libfontconfig.so
[task 2019-07-25T12:16:51.575Z] 12:16:51 INFO - PID 25911 | 1 29 libglib-2.0.so

Regressed by: 1567435
Summary: Intermittent TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html | when Gecko 70 merges to Beta on 2019-08-26 → Permafail TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworklet-addmodule-resolution.https.html | when Gecko 70 merges to Beta on 2019-08-26

This is expected fall-out from removal of expectation metadata: https://hg.mozilla.org/integration/mozilla-inbound/rev/dbb4eb578278#l440.1

James, I've read https://bugzilla.mozilla.org/show_bug.cgi?id=1564917#c1 and IIUC this condition should have been preserved. Is that your expectation?

Flags: needinfo?(james)

Yeah, the intent at least is that conditions that refer to a thing that isn't part of the update run, and use variables that aren't defined in the update set, are preserved. So if release_or_beta: should be preserved but if not release_or_beta: shouldn't (because it matches the nightly builds in the update runs).

If that isn't happening it seems like a bug.

Flags: needinfo?(james)
Depends on: 1569559
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f74fefd81240
restore release_or_beta expectation metadata on the-audioworklet-interface tests. r=jgraham
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → csabou

No longer occurs on beta sims.

Status: RESOLVED → VERIFIED
See Also: → 1581108
You need to log in before you can comment on or make changes to this bug.