Closed Bug 1568925 Opened 2 months ago Closed 2 months ago

Some "bootstrap" (or rather vcs-setup) descriptive text gets colorized as if it were part of the prompt

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(3 files)

When I run ./mach bootstrap on today's mozilla-central tip, the prompts all get colored differently from the rest of the text (brown vs. white, in my terminal), which is nice.

However, when it gets to the format-source section, there's a problem -- the prompt is on the same line as some prior explanatory text, so an arbitrary snippet of non-prompt explanatory text (the phrase can be used in most cases) gets colorized along with the prompt.

This looks kinda broken -- see screenshot. We probably need to insert a newline before the prompt, or something, so that the explanatory text is all colored consistently.

Duplicate of this bug: 1568926

This chunk of output is actually more-specifically part of ./mach vcs-setup (which gets invoked by ./mach bootstrap).

Summary: Some "bootstrap" descriptive text gets colorized as if it were part of the prompt → Some "bootstrap" (or rather vcs-setup) descriptive text gets colorized as if it were part of the prompt
Component: Bootstrap Configuration → General

Pushed by cosheehan@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/99dca4809de4
hgext: Add a newline between 'format-source' descriptive text and yes/no prompt. r=sheehan

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Pushed by cosheehan@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/61c65ae8b33b
configwizard: fix `test-format-source.t` output
You need to log in before you can comment on or make changes to this bug.