Cannot attach Word 2001 file containing footnotes

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: michael.graubart7, Assigned: bugzilla)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061103

If a MS Word 2001 document has diagrams or illustrations in JPEG format (PICT or
other formats have not been tried) inserted into it, it cannot be attached and
sent.  If this is attempted,for example, with such a file called 'X' in a folder
'Y' on the desktop, the 'Attachments' pane shows 'Hard disk//desktop/folder
X/file Y' and starts a long process of loading and a message;'Sending mail
failed' appears.  A Word 2001 document without images can be attached and sent
perfectly well.  I do not know whether the malfunctioning with files containing
diagrams, etc., is a matter merely of the larger size, or whether it is inherent
in the inclusion of images.

Contrary to a bug reported by someone else, I have had no difficulty attaching a
Word 6/95 file that did not contain images.

I earlier reported failure to be able to attach Word 6/95 documents to Netscape
7 mail to the Netscape feedback centre, but this seems to have been curted in
Mozilla 1.1a. 



Reproducible: Didn't try
Steps to Reproduce:
1. Create a Word 2001 word-processor file.
2. Create a drawing or EPS music example, convert it to JPEG format and insert
it into the Word file.
3. Save the resulting compound file.
4. Click 'Attach' in the 'Compose' window of Mozilla, locate the saved file,
click 'Open.

Actual Results:  Mozilla seems to try to attach the whole desktop and folder as
well as the actual file.  'Sending mail failed' appears.

Expected Results:  Just the actual selected file should appear in the
Attachments pane, and it should then be possible to send the message with its
attachment.

Classic theme.

'Rich text and plain text' were selected in 'Options' before composing the
e-mail and trying to attach the Word 2001 file.
(Reporter)

Comment 1

17 years ago
I have to modify this report.  It turns out that it is not the inclusion of JPEG
images that prevents a Word 2001 file being attached and sent, but the presence
of footnotes in the typed word-processor text.

Without footnotes, the file can be attached and sent despite including diagrams,
etc., in JPEG format.

NB: In Netscape 4.79 this problem does not arise.

Updated

17 years ago
QA Contact: esther → trix

Comment 2

17 years ago
Corrected the bug summary to reflect your modification.

Also, to my understanding Mozilla does not examine the file for anything... a
file is a file.  Weird.  I think your problem lies elsewhere.
Summary: Cannot attach Word 2001 file if this includes JPEG images → Cannot attach Word 2001 file containing footnotes

Comment 3

17 years ago
do you have the file open in Word while trying to send it?
At least previous versions of word used to disable any file handling if it was open.
(Reporter)

Comment 4

17 years ago
No, I definitely did not have the file open.  But thank you.  I am researching
the matter further.  I have now tried it again with a newly created, very short
document containing one footnote, and this did attach perfectly well, so I am
totally at a loss at the moment to explain why my longer musicological article
had to be sent via different mailer.
(Assignee)

Comment 5

17 years ago
We might have some problem depending on the size of the file. Can you tell me
the size of the file that doesn't work and the size of the one that works once
you have removed the footnotes?
(Reporter)

Comment 6

17 years ago
They were both around 64K - very small, really.  But the inexplicable thing is
that I tried it several times and it never worked; then, after reporting the
failure and receiving various comments - like the present one - I went back to
it, and all the versions - with JPEG images and footnotes, without images but
with footnotes and without either - worked perfectly well.

Comment 7

16 years ago
Michael, please attach an example file so others can verify the bug. (I don't have Word 2001, so 
I can't create one.)
Severity: normal → major
(Reporter)

Comment 8

16 years ago
This was a false alarm. I don't know what happened, but it might have been
another case of a document with a title that contained something like a slash. 
I have had no difficulties with Word 2001 or Word 6 documents since this title
business has been resolved, but I still think that it might be worth making
Mozilla (like Netscape 4.79) more tolerant of aberrant titles.

Comment 9

16 years ago
Resolving WFM per reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
changing qa contact to yulian
QA Contact: trix → yulian
QA Contact: yulian → stephend
I don't have access to Word 2001 on Mac OS 9.2.2, so I can't verify this based
on my own experience.

So, I'm trusting comment 8 in my verification.  Thanks!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

16 years ago
Re Stephen Donner's comment (no.11): I thought this one had been resolved as per
comment no.8. (I apologize for starting this hare that continues, apparently, to
run long after it was shot!) But I still think life would be made much easier if
Mozilla were as tolerant of file names as Netscape 4.7 and other mail clients.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.