Closed Bug 1569012 Opened 4 years ago Closed 4 years ago

Nightly crash in [@ objc_msgSend | imgRequestProxy::Notify]

Categories

(Core :: Graphics: ImageLib, defect, P2)

68 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: MattN, Unassigned)

References

(Regression, )

Details

(Keywords: crash, dogfood, regression)

Crash Data

Upon visiting https://wiki.mozilla.org/RapidRelease/Calendar I got a crash both times. I also got a crash doing a Bugzilla search for an existing crash bug.

This bug is for crash report bp-fcf4c582-aab8-4545-bcbe-8869d0190725.

Top 10 frames of crashing thread:

0 libobjc.A.dylib objc_msgSend 
1 XUL imgRequestProxy::Notify image/imgRequestProxy.cpp:1018
2 XUL void mozilla::image::SyncNotifyInternal<mozilla::image::ObserverTable const*> image/ProgressTracker.cpp:333
3 XUL mozilla::image::ProgressTracker::SyncNotifyProgress image/ProgressTracker.cpp:370
4 XUL mozilla::image::RasterImage::NotifyProgress image/RasterImage.cpp:1622
5 XUL mozilla::image::RasterImage::NotifyDecodeComplete image/RasterImage.cpp:1656
6 XUL mozilla::detail::RunnableFunction<mozilla::image::IDecodingTask::NotifyDecodeComplete image/IDecodingTask.cpp:123
7 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225
8 XUL NS_ProcessPendingEvents xpcom/threads/nsThreadUtils.cpp:434
9 XUL nsBaseAppShell::NativeEventCallback widget/nsBaseAppShell.cpp:87

Looks exclusive to mac, showed up first with 20190724220024 build, there are a bunch of crashes already that make it seem pretty sure that is the build it started with. Changes in that build:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5585edba8fdb83267722e62241952272c8e24a8f&tochange=1da5a37de0fd1695e96a9d5e7f59fbd84d8759b2

I'm going to guess
https://hg.mozilla.org/mozilla-central/rev/4aead1eca8c65fab12771084a3be639564fc1b61
bug 1521893, because it changed some image observers and is mac only.

Regressed by: 1521893
Flags: needinfo?(htwyford)
Priority: -- → P3

I can reproduce this on my Nightly on the Google search home page. And by going to about:support.

This is on Nightly 2019-07-26 on my 2015 MBP (no touchbar).

I have WebRender disabled.

Here are some crash reports:
https://crash-stats.mozilla.org/report/index/e65ea9c8-0531-42e7-ba4a-033960190726
https://crash-stats.mozilla.org/report/index/c566dfc7-2453-4ef9-97da-82b430190726

Weird, I can not reproduce on my 2015 MBP by going to any of the mentioned pages here. I had assumed it required a touchbar until you commented.

Priority: P3 → P2

I also can't replicate on a MBP with Touch Bar. It's especially weird that this occurs on non-Touch Bar Macs, since https://hg.mozilla.org/mozilla-central/rev/4aead1eca8c65fab12771084a3be639564fc1b61 mainly introduced a class does nothing unless a Touch Bar is present on the Mac. There were a small handful of changes that affected Macs regardless of Touch Bar status. I'm not clearing needinfo since I'll continue to look into if the latter changes are causing this issue.

Priority: P2 → P3
Priority: P3 → P2

I also don't have a touchbar as I'm using a 2013 MBP. Since this is already the #3 macOS crasher on Nightly perhaps we should back out the offending patch? I had to downgrade Nightly in order to do work and it's sounding like this is a crash for anyone without a touchbar.

[Tracking Requested - why for this release]: Common crash on macOS (for users without a touch bar?)

Keywords: dogfood
Crash Signature: [@ objc_msgSend | imgRequestProxy::Notify] → [@ objc_msgSend | imgRequestProxy::Notify] [@ objc_msgLookupSuper2]

On my MBP (2017 with touchbar, macOS 10.14.6), I seem I enconut this crash frequently when I switch the focus to Firefox window from other application. But it happens randomly and I could not find the concrete steps to reproduce.

(Quoting Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from bug 1568862 comment #10)

Backed out part 2 of bug 1521893 to fix crashes (Bug 1568862):

https://hg.mozilla.org/integration/autoland/rev/4b23bb4e274c0c0d69b7be2d3cd6090a971a837e

I think we can call the spike from bug 1521893 fixed now.

Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(htwyford)
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
QA Whiteboard: [qa-70b-p2]
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.