Closed Bug 1569182 Opened 1 year ago Closed 1 year ago

[Protections Panel] Update shield and lock icon/buttons to match spec

Categories

(Firefox :: Theme, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: nhnt11, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [skyline][privacy-panel])

Attachments

(1 file)

  1. The shield button needs to start at the very edge of the url bar - currently there is a few pixels of whitespace between them.
  2. The dimensions of the lock and shield icons should be square, this will make their hover-state backgrounds match the spec.
  3. The final resulting layout/spacing between icons should match the spec
  4. There needs to be a divider line between the two buttons, kinda like between one-off buttons in the search UI or between tabs when drag space is enabled.
Summary: [Protections Panel] Shield icon hover background should extend to the end of the URL bar. → [Protections Panel] Update total size of shield and lock icon/buttons
Summary: [Protections Panel] Update total size of shield and lock icon/buttons → [Protections Panel] Update shield and lock icon/buttons to match spec
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [privacy-panel][triage][skyline] → [skyline]
Whiteboard: [skyline] → [skyline][privacy-panel]
Attachment #9081051 - Attachment description: Bug 1569182 - [Protections Panel] Update shield and lock icon/buttons to match spec. r=johannh → Bug 1569182 - [Protections Panel] Update shield and lock icon/buttons to match spec. r=timhuang
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a9f37a8db551
[Protections Panel] Update shield and lock icon/buttons to match spec. r=timhuang
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Duplicate of this bug: 1568506
Regressions: 1570248
Type: task → enhancement
Component: Site Identity and Permission Panels → Theme
No longer depends on: 1569872
Regressions: 1569872
Regressions: 1570251
You need to log in before you can comment on or make changes to this bug.