Closed Bug 1569244 Opened 4 months ago Closed 4 months ago

Blocking all addons via policy uninstalls search, themes and all plugins

Categories

(Firefox :: Enterprise Policies, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 69+ verified
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: mkaply, Assigned: mkaply)

Details

(Keywords: dataloss)

Attachments

(1 file)

Setting the new ExtensionSettings policy to block "*" causes search addons, plugins, and the default theme to be uninstalled.

Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/2248a49a2dfd
Only uninstall extensions if they are in the profile. r=kmag
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+

Tested on Fx 70.0a1 on windows 10 x64, Ubuntu 18.04 and macOS 10.13. Setting '*' for ExtensionSettings correctly removes the already installed addons, themes or plug-in search engines.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9080989 [details]
Bug 1569244 - Only uninstall extensions if they are in the profile.

Beta/Release Uplift Approval Request

  • User impact if declined: New ExtensionSettings policy uninstalls search.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: In bug.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only affects policy
  • String changes made/needed:
Attachment #9080989 - Flags: approval-mozilla-release?
Attachment #9080989 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9080989 [details]
Bug 1569244 - Only uninstall extensions if they are in the profile.

Sounds like a scary regression, approved for 69.0b10 so we can get some wider feedback on the patch. Is this something we could add automated test coverage for? Also, is this something we should consider for ESR68 uplift also?

Attachment #9080989 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

It's not a regression. This was a new policy in 68 and this was missed in the testing because it only happened in new profile situations. And yes, I'll request 68 uplift. I had forgotten last night.

Comment on attachment 9080989 [details]
Bug 1569244 - Only uninstall extensions if they are in the profile.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Fixes new ExtensionSettings policy on ESR
  • User impact if declined: ExtensionSettings policy can't be used
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Policy only.
  • String or UUID changes made by this patch:
Attachment #9080989 - Flags: approval-mozilla-esr68?

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Keywords: regression

Tested the implementation on the latest available beta (Fx69.0b11). Also placed an addon outside the profile folder - inside the Extensions folder and that addon was not removed by applying the policy (as intended), it was only disabled. Tested on macOS 10.14, Ubuntu 18.04 and Windows 10 x64.

Waiting for the uplift to be done ESR as well.

I'm tempted to punt this to 68.1esr and 69. Would that be ok, possibly with an addition to the "known issues" section of the 68.0 release notes?

Flags: needinfo?(mozilla)

I'm tempted to punt this to 68.1esr and 69. Would that be ok, possibly with an addition to the "known issues" section of the 68.0 release notes?

Any particular reason? The fix is very self contained. This was a policy that we really wanted to debut in 68, but had to hold off because of this bug.

At this point, though, we've removed any information about it, so it wouldn't need to be in the release notes.

Flags: needinfo?(mozilla)

It's not a regression so nobody depends on this yet and 69 / 68.1 is less than 4 weeks away

That's fair. I'm fine with that.

Comment on attachment 9080989 [details]
Bug 1569244 - Only uninstall extensions if they are in the profile.

policy fix, approved for 68.1esr

Attachment #9080989 - Flags: approval-mozilla-release?
Attachment #9080989 - Flags: approval-mozilla-release-
Attachment #9080989 - Flags: approval-mozilla-esr68?
Attachment #9080989 - Flags: approval-mozilla-esr68+

This issue is verified fixed using Firefox 68.1.0esr (provided in comment 17) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 18.04 64bit.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.