Closed Bug 1569414 Opened 1 year ago Closed 1 year ago

Intermittent browser/components/migration/tests/unit/test_Chrome_history.js | test_import - [test_import : 83] Should have stored an entry - null == true

Categories

(Firefox :: Migration, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: MattN)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=258647931&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/QZqBM4V-Q722UuTIF3MrHQ/runs/0/artifacts/public/logs/live_backing.log


task 2019-07-27T13:53:59.241Z] 13:53:59 INFO - TEST-START | browser/components/migration/tests/unit/test_Chrome_history.js
[task 2019-07-27T13:53:59.977Z] 13:53:59 WARNING - TEST-UNEXPECTED-FAIL | browser/components/migration/tests/unit/test_Chrome_history.js | xpcshell return code: 0
[task 2019-07-27T13:53:59.977Z] 13:53:59 INFO - TEST-INFO took 727ms
[task 2019-07-27T13:53:59.977Z] 13:53:59 INFO - >>>>>>>
[task 2019-07-27T13:53:59.977Z] 13:53:59 INFO - PID 3703 | [3703, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2634
[task 2019-07-27T13:53:59.977Z] 13:53:59 INFO - PID 3703 | [3703, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, kKnownEsrVersion) failed with result 0x80004002: file /builds/worker/workspace/build/src/toolkit/components/resistfingerprinting/nsRFPService.cpp, line 661
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - PID 3703 | [3703, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file /builds/worker/workspace/build/src/extensions/permissions/nsPermissionManager.cpp, line 2903
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - running event loop
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - browser/components/migration/tests/unit/test_Chrome_history.js | Starting setup
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test setup pending (2)
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test run_next_test 1 pending (2)
[task 2019-07-27T13:53:59.978Z] 13:53:59 INFO - (xpcshell/head.js) | test setup finished (2)
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - browser/components/migration/tests/unit/test_Chrome_history.js | Starting test_import
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - (xpcshell/head.js) | test test_import pending (2)
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - (xpcshell/head.js) | test run_next_test 1 finished (2)
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - TEST-PASS | browser/components/migration/tests/unit/test_Chrome_history.js | test_import - [test_import : 151] Sanity check the source exists - true == true
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - TEST-PASS | browser/components/migration/tests/unit/test_Chrome_history.js | test_import - [test_import : 57] Resource supported by migrator - true == true
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - "Checking url: http://example.com/"
[task 2019-07-27T13:53:59.979Z] 13:53:59 WARNING - TEST-UNEXPECTED-FAIL | browser/components/migration/tests/unit/test_Chrome_history.js | test_import - [test_import : 83] Should have stored an entry - null == true
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - /Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/tests/browser/components/migration/tests/unit/test_Chrome_history.js:assertEntryMatches:83
[task 2019-07-27T13:53:59.979Z] 13:53:59 INFO - /Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/tests/browser/components/migration/tests/unit/test_Chrome_history.js:test_import:166
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - exiting test
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - Unexpected exception NS_ERROR_ABORT:
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - _abort_failed_test@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:788:20
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - do_report_result@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:889:5
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - Assert<@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:66:5
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - proto.report@resource://testing-common/Assert.jsm:233:10
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - proto.ok@resource://testing-common/Assert.jsm:259:10
[task 2019-07-27T13:53:59.980Z] 13:53:59 INFO - assertEntryMatches@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/tests/browser/components/migration/tests/unit/test_Chrome_history.js:83:10
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - test_import@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/tests/browser/components/migration/tests/unit/test_Chrome_history.js:166:5
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - async*run_next_test/_run_next_test/<@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:1564:22
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - _run_next_test@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:1564:38
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - run@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:732:9
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - _do_main@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:245:6
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - _execute_test@/Users/cltbld/tasks/task_1564230584/build/tests/xpcshell/head.js:572:5
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - @-e:1:1
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - exiting test
[task 2019-07-27T13:53:59.981Z] 13:53:59 INFO - PID 3703 | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | [3703, Main Thread] WARNING: OOPDeinit() without successful OOPInit(): file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 3116
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | [3703, Main Thread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp, line 194
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | [3703, Main Thread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp, line 194
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | nsStringStats
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | => mAllocCount: 12570
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | => mReallocCount: 0
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | => mFreeCount: 12570
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | => mShareCount: 10429
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | => mAdoptCount: 244
[task 2019-07-27T13:53:59.982Z] 13:53:59 INFO - PID 3703 | => mAdoptFreeCount: 248
[task 2019-07-27T13:53:59.983Z] 13:53:59 INFO - PID 3703 | => Process ID: 3703, Thread ID: 4495570368
[task 2019-07-27T13:53:59.983Z] 13:53:59 INFO - <<<<<<<

The issue is a time bomb with the history records being older than 6 months:

ChromeMigrationUtils.chromeTimeToDate(13193151310368000)

Mon Jan 28 2019 04:15:10 GMT-0800

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Priority: P5 → P1
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/9391eb2b4fff
Don't hardcode a too old history visit date in test_Chrome_history.js.
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e3b9ca5a13b
Don't hardcode a too old history visit date in test_Chrome_history.js.
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.