Closed Bug 1569917 Opened 3 months ago Closed 3 months ago

Change the string on the doorhanger when adding a username to a login

Categories

(Toolkit :: Password Manager, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: tbabos, Assigned: MattN)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [passwords:capture-UI] [passwords:generation])

Attachments

(4 files)

Attached image Screenshot of issue

Affected versions
Nightly 70.0a1 (2019-07-29) (64-bit)

Affected platforms
All

Steps to reproduce

  • Launch Firefox
  • Go to a log in page, such as: https://twitter.com/
  • Fill in the password field with a generated password
  • Click on the blue key icon

Expected result
The dismissed doorhanger's string should be "Would you like to update this login" given that the username is missing.

Actual Result
The "Would you like to update this password?" string is displayed for the doorhanger in the described scenario.

Notes:
Submitted bug as discussed in https://bugzilla.mozilla.org/show_bug.cgi?id=1559991#c12

Ryan and I discussed this last week and came to a similar conclusion but this isn't limited to generated passwords, it also applies when you have a saved login without a username but then submit a login form with a username (see bug 1016051).

We were considering a more specific string of "Would you like to add a username to this login?". That string would have to change if the user then edits the password field but we already have the button string being live so hopefully it doesn't cause too much of a shift.

Betsy, is the string "Would you like to add a username to this login?" good for the doorhanger when we already have a saved password (without a username) but now have a username to add?

Blocks: 1016051
Type: defect → enhancement
Flags: qe-verify+
Flags: needinfo?(bmikel)
Priority: -- → P2
Summary: Change the string on the dismissed doorhanger for a generated password without username → Change the string on the doorhanger when adding a username to a login
Whiteboard: [passwords:capture-UI] [passwords:generation]
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED

Some options get passed directly to PopupNotifications.show while others are for use by LMP. Passing arbitrary parameters to PopupNotifications.show could cause problems down the road.

Make it more clear that the password isn't changing, only the username.

Depends on D40221

Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/a3672308e8d3
Split showOptions from others on _showLoginCaptureDoorhanger. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/74256ae92982
Change the string on the doorhanger when adding a username to a login. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Thanks for giving me a good string to start with. Let's go with this, which is more concise Add a username to this login?

Flags: needinfo?(bmikel)

These are the test results:

  1. The case when you have a saved login without a username (Yahoo/Twitter):
    "Would you like to update this password?"
  • Considering Timea's suggestion, I think this string could be changed with one like:
    "Would you like to update this login?" given that the username is missing.
  1. The case when you have a saved login without a username but then submit a login form with a username (Google):
    "Would you like to add a username to the saved password?"
  • Which one is the intended string? The one implemented in this bug is the one above and it is displayed on two rows. Please consider that the string given in comment 6 would fit in one row ("Add a username to this login?").

Betsy, What do you think?

Flags: needinfo?(bmikel)

(In reply to Bodea Daniel [:danibodea] from comment #7)

These are the test results:

  1. The case when you have a saved login without a username (Yahoo/Twitter):
    "Would you like to update this password?"

Is this when a username isn't submitted on the same page?

  • Considering Timea's suggestion, I think this string could be changed with one like:
    "Would you like to update this login?" given that the username is missing.

We use "login" when you have both a username and password, and "password" otherwise so I was being consistent with our existing strings and UX direction.

  1. The case when you have a saved login without a username but then submit a login form with a username (Google):
    "Would you like to add a username to the saved password?"
  • Which one is the intended string? The one implemented in this bug is the one above and it is displayed on two rows. Please consider that the string given in comment 6 would fit in one row ("Add a username to this login?").

The string I used was before Betsy replied and aligns with the format of the existing strings which include the "Would you like to…". I'm not sure it makes sense to change only one variation to not include that. See https://hg.mozilla.org/integration/autoland/diff/74256ae92982c6d067b218c6f45d4ee91a4f2081/toolkit/locales/en-US/chrome/passwordmgr/passwordmgr.properties#l1.10 for related strings.

My preference would be to remove Would you like to… in these instances. It's more concise and considerate to the user to get to the point. I don't have a good grasp on where these strings stand right now though, and how much effort it would be to change them.

Flags: needinfo?(bmikel)

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #8)

(In reply to Bodea Daniel [:danibodea] from comment #7)

These are the test results:

  1. The case when you have a saved login without a username (Yahoo/Twitter):
    "Would you like to update this password?"

Is this when a username isn't submitted on the same page?

Yes.

  • Considering Timea's suggestion, I think this string could be changed with one like:
    "Would you like to update this login?" given that the username is missing.

We use "login" when you have both a username and password, and "password" otherwise so I was being consistent with our existing strings and UX direction.

I'm thinking that the most probable user flow would be the one where the user would open the dismissed doorhanger and update the login with a manually input username.

  1. The case when you have a saved login without a username but then submit a login form with a username (Google):
    "Would you like to add a username to the saved password?"
  • Which one is the intended string? The one implemented in this bug is the one above and it is displayed on two rows. Please consider that the string given in comment 6 would fit in one row ("Add a username to this login?").

The string I used was before Betsy replied and aligns with the format of the existing strings which include the "Would you like to…". I'm not sure it makes sense to change only one variation to not include that. See https://hg.mozilla.org/integration/autoland/diff/74256ae92982c6d067b218c6f45d4ee91a4f2081/toolkit/locales/en-US/chrome/passwordmgr/passwordmgr.properties#l1.10 for related strings.

I am just trying to make sure that the best variation of the string wins.

(In reply to Betsy Mikel [:betsymi] from comment #9)

My preference would be to remove Would you like to… in these instances. It's more concise and considerate to the user to get to the point. I don't have a good grasp on where these strings stand right now though, and how much effort it would be to change them.

I will try to explain where exactly where these strings are being displayed:
When the user arrives on a page with a password field and generates a password in the field, the password is instantly saved and a message is displayed saying that the password has been saved. At this point, there are 2 cases:

  1. The case where the username isn't submitted on the same page, so if the user clicks the "key-like" icon from the address bar, the doorhanger displayed shows the text: "Would you like to update this password?" and a masked password with no username.
  2. The case where the username is submitted on the same page, so if the user clicks the "key-like" icon from the address bar, the doorhanger displayed shows the text: "Would you like to add a username to the saved password?" and a masked password with a username.
  • Considering case 2, the one addressed in this bug, I would also choose the more concise string because it looks a lot better displayed in a single row.
  • Furthermore, this bug was intended to address the first case, where the user has a password displayed on the doorhanged, but not a username, this is where the user might think "I should probably add the right username to this login so that the password will be auto-filled next time. ("Would you like to update this login?" instead of "Would you like to add a username to the saved password?").
Flags: needinfo?(bmikel)
Flags: needinfo?(MattN+bmo)

Verified - Fixed on latest Beta 70.0b3 (64-bit) on Windows 10 x64 and Mac OS 10.14.
The "Would you like to add a username to the saved password?" string will be displayed when we add a username to an already saved generated or manually written password.

Expected results based on: https://hg.mozilla.org/integration/autoland/diff/74256ae92982c6d067b218c6f45d4ee91a4f2081/toolkit/locales/en-US/chrome/passwordmgr/passwordmgr.properties#l1.10 mentioned in Comment 8.

Removing the NI? from Dani given that a decision has already been made regarding the string and it has also been applied via a patch.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(bmikel)
Flags: needinfo?(MattN+bmo)
You need to log in before you can comment on or make changes to this bug.