Closed Bug 1569943 Opened 3 months ago Closed 3 months ago

./mach android install-geckoview_example reconfigures the build

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1561323

People

(Reporter: emilio, Unassigned)

References

(Blocks 1 open bug)

Details

Difference between .mozconfig.json of regular ./mach build (.old) and the one that ./mach android install-geckoview_example produces:

diff --git a/mozconfig.json.old b/obj-android-emulator-debug-noopt/.mozconfig.json
index 650cfd9ae68f..cb984dc24b6d 100644
--- a/mozconfig.json.old
+++ b/obj-android-emulator-debug-noopt/.mozconfig.json
@@ -43,7 +43,7 @@
         ], 
         "BASH_ARGV": [
           "()", 
-          "([0]=\"/home/emilio/src/moz/gecko-4/python/mozbuild/mozbuild/action/dump_env.py\" [1]=\"/usr/bin/python2.7\" [2]=\"/home/emilio/src/moz/gecko-4/mozconfig\" [3]=\"/home/emilio/src/moz/gecko-4\")"
+          "([0]=\"/home/emilio/src/moz/gecko-4/python/mozbuild/mozbuild/action/dump_env.py\" [1]=\"/home/emilio/src/moz/gecko-4/obj-android-emulator-debug-noopt/_virtualenvs/init/bin/python\" [2]=\"/home/emilio/src/moz/gecko-4/mozconfig\" [3]=\"/home/emilio/src/moz/gecko-4\")"
         ]
       }, 
       "removed": {},

Hmm, I cannot repro the rebuild of C++ code consistently, weird.

But the reconfigure is consistent.

Mozconfig for reference:

MOZCONFIGS=/home/emilio/.mozconfigs
mk_add_options AUTOCLOBBER=1
. "$MOZCONFIGS/android"

ac_add_options --target=i686-linux-android
ac_add_options --enable-debug
ac_add_options --disable-optimize
mk_add_options MOZ_OBJDIR=/home/emilio/src/moz/gecko-4/obj-android-emulator-debug-noopt

(obviously various paths there need to be adjusted)

$MOZCONFIGS/android is:

. "$MOZCONFIGS/android-icecc-hack"

ac_add_options --enable-application=mobile/android
ac_add_options --with-android-ndk=/home/emilio/.mozbuild/android-ndk-r17b

And $MOZCONFIGS/android-icecc-hack is:

# Android hack to make cross builds work with icecc
HOST_CC="/home/emilio/.mozbuild/clang/bin/clang"
HOST_CXX="/home/emilio/.mozbuild/clang/bin/clang++"
CC="/home/emilio/.mozbuild/clang/bin/clang"
CXX="/home/emilio/.mozbuild/clang/bin/clang++"
ac_add_options --with-ccache

Which is because otherwise icecc+ccache gets confused with my regular ICECC_PREFIX setup. Nothing that should matter much here, I think.

Summary: ./mach android install-geckoview_example reconfigures the build and causes a rebuild of C++ code → ./mach android install-geckoview_example reconfigures the build

I actually didn't have bug 1561323 on my tree.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1561323

(In reply to Emilio Cobos Álvarez (:emilio) from comment #0)

Difference between .mozconfig.json of regular ./mach build (.old) and the one that ./mach android install-geckoview_example produces:

diff --git a/mozconfig.json.old b/obj-android-emulator-debug-noopt/.mozconfig.json
index 650cfd9ae68f..cb984dc24b6d 100644
--- a/mozconfig.json.old
+++ b/obj-android-emulator-debug-noopt/.mozconfig.json
@@ -43,7 +43,7 @@
         ], 
         "BASH_ARGV": [
           "()", 
-          "([0]=\"/home/emilio/src/moz/gecko-4/python/mozbuild/mozbuild/action/dump_env.py\" [1]=\"/usr/bin/python2.7\" [2]=\"/home/emilio/src/moz/gecko-4/mozconfig\" [3]=\"/home/emilio/src/moz/gecko-4\")"
+          "([0]=\"/home/emilio/src/moz/gecko-4/python/mozbuild/mozbuild/action/dump_env.py\" [1]=\"/home/emilio/src/moz/gecko-4/obj-android-emulator-debug-noopt/_virtualenvs/init/bin/python\" [2]=\"/home/emilio/src/moz/gecko-4/mozconfig\" [3]=\"/home/emilio/src/moz/gecko-4\")"
         ]
       }, 
       "removed": {},

Thanks for this detailed report, which confirms that Bug 1561323 should address the issue. Out of interest, are you running with +x or something similar in your default bash configuration?

I don't think so, definitely not in my bash profile or .bashrc, but there's so much in /etc/profile/*.sh that it's hard to say.

You need to log in before you can comment on or make changes to this bug.