Closed Bug 1569950 Opened 2 months ago Closed 2 months ago

6.95 - 10.95% tscrollx (windows10-64-shippable-qr) regression on push ca1ff794e472f28f0f65cd93af158957c112dc62 (Wed July 17 2019)

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX
mozilla70
Tracking Status
firefox70 --- wontfix

People

(Reporter: alexandrui, Assigned: lsalzman)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, regression, talos-regression)

Attachments

(1 file)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=ca1ff794e472f28f0f65cd93af158957c112dc62

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

11% tscrollx windows10-64-shippable-qr opt e10s stylo 0.77 -> 0.85
7% tscrollx windows10-64-shippable-qr opt e10s stylo 0.77 -> 0.82

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=22196

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Flags: needinfo?(lsalzman)
Component: General → Graphics: WebRender
Priority: -- → P3
Product: Testing → Core
Target Milestone: --- → mozilla70
Version: Version 3 → unspecified
Duplicate of this bug: 1569954

I am working on a fix for this at the moment, but until then the slight regression is okay, because it still at least improves the end-user experience by eliminating jank as it is.

Flags: needinfo?(lsalzman)
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b5c9358aa68
only partially clear WR glyph caches if it is not necessary to fully clear. r=kvark
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Assignee: nobody → lsalzman

Hi. I don't see any improvement from this push.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

For now we are okay with accepting this regression as the alternative is higher memory usage and jank, so the patch still improves the user experience despite what Talos says.

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.