Closed Bug 1570165 Opened 2 months ago Closed 2 months ago

Port |Bug 517902 - "Reimplement image properties, using the existing "Media" panel"| to SeaMonkey

Categories

(SeaMonkey :: Page Info, enhancement)

enhancement
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.67
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file, 2 obsolete files)

Port following bugs:

  • Bug 517902 - "Reimplement image properties, using the existing "Media" panel"
  • Bug 524106 - "View Image Info" selects the wrong image when there are multiple images with the same src
  • Bug 526534 - Page Info does not detect multiple instances of the same image on a page if no alt text is provided or the alt text is the same
  • Bug 526721 - "View Image Info" displays the wrong size if the document's first image has the same url, same alt but different scale
  • Bug 524090 - make "View Image Info" scroll to the selected image in the Page Info media tab
Attached patch Port patches (obsolete) — Splinter Review
Attachment #9081801 - Flags: review?(frgrahl)
Duplicate of this bug: 1569962
Attached patch Port patches v1.1 (obsolete) — Splinter Review

Fold in the patch from bug 1569962

Attachment #9081801 - Attachment is obsolete: true
Attachment #9081801 - Flags: review?(frgrahl)
Attachment #9081816 - Flags: review?(frgrahl)
Blocks: 1569962
Comment on attachment 9081816 [details] [diff] [review]
Port patches v1.1

> /suite/browser/navigator.js
> +// imageElement - image to load in the Media Tab of the Page Info window; can be null/omitted

NIT:
Line is a bit longer than 80. And a certain reviewer once told me I should end comments with a period (goes for other comments here too) :)

> suite/browser/pageinfo/pageInfo.js
Could use the fix for Bug 524090 too. The image is selected but not always visible.
Attachment #9081816 - Flags: review?(frgrahl)
Attachment #9081816 - Flags: review+
Attachment #9081816 - Flags: approval-comm-release+
Attachment #9081816 - Flags: approval-comm-esr60+

Added port from:

  • Bug 524090 - make "View Image Info" scroll to the selected image in the Page Info media tab
    Updated comment so it is not too long, though now longer matches the original patch, no full stop needed as it starts lower case :)
    Carrying forward r+/a+
Attachment #9081816 - Attachment is obsolete: true
Attachment #9081926 - Flags: review+
Attachment #9081926 - Flags: approval-comm-release+
Attachment #9081926 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/f1d9d8df995e
Port Bug 517902 "Reimplement image properties, using the existing "Media" panel" to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Blocks: 1573595
You need to log in before you can comment on or make changes to this bug.