URL encoding/access problems

VERIFIED DUPLICATE of bug 170241

Status

VERIFIED DUPLICATE of bug 170241
17 years ago
11 years ago

People

(Reporter: mozilla, Assigned: mscott)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
OS:Win98 SE
Mozilla: version 1.1a, build ID #2002061104

When I click on any link in the attached e-mail it enters the URL into the
browser with all the "."s changed to "%2E"s. (Ex. it changes
"http://go.msn.com/AA/0" to "http://go%2Emsn%2Ecom/AA/0/") And I've checked that
the e-mail is correct because  when I hover over the links they appear in the
status bar without the substitution, and when I perform the substitution the
URLs work. I am pretty sure it has something to do with encoding.
(Reporter)

Comment 1

17 years ago
Created attachment 91202 [details]
Example Message

Updated

17 years ago
QA Contact: gayatri → olgam

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 170241 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
The problem here is that status bar unescapes the URL to make your life as an
end user easier. This is not considered the greatest behavior by some, including me.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.