If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clicking on certain e-mail messages causes Mozilla to crash.

VERIFIED DUPLICATE of bug 156650

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED DUPLICATE of bug 156650
15 years ago
13 years ago

People

(Reporter: Rob North, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.04 KB, text/plain
Details
(Reporter)

Description

15 years ago
Build: 2002071008
Clicking on certain messages in the message list causes mozilla to crash.
This seems to be repeatable with certain messages.

The messages were ones that should have matched mail filters, but were now in
wrong folder.

Quality feed back agent IDs for this problem were:
TB8227608E
TB8227434G
TB8227362M
TB8226916Y
(Reporter)

Updated

15 years ago
Severity: normal → critical
Are subjects empty? In that case.. dupe of bug 156650
(Reporter)

Comment 2

15 years ago
Ok I've been doing some digging, and have more info on the bug:

Initially, I could see subjects for all messages in the mail folder.
Attempted to remove .msf file for problem folder.
This did not cure the problem, but now many messages are showing up wilth "-"
for their subject.
Examining the mail file shows that essential headers are missing from many
mssages, and some messages contain content similar in appearance to .msf files.

This suggests this bug splits in two:
A front end bug, where a corrupt database crashes mozilla. (bug 156650??)
A back end bug that corrupts the database.

A typical corrupt message would be the following:

From - Thu Jul 11 23:59:54 2002
X-UIDL: pseudopode.1026427260:20:15102:14
X-Mozilla-Status: 0000
X-Mozilla-Status2: 00000000
Return-Path: <ticket_erp.yynj1761026427185434@sneakemail.com>
Received: from punt-2.mail.demon.net by mailstore
<More received lines here, last one is truncated>
<Message body here>

Comment 3

15 years ago
Created attachment 91173 [details]
Stacks

Here is the stack from one of the incidents mentioned. (I checked the others
and they were consistent with this one.)

Comment 4

15 years ago
The signature in the call stack points to 156630, which points back to 156650
(as mentioned in comment #1).

Marking this a dupe of bug 156650. 

*** This bug has been marked as a duplicate of 156650 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: crash
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.