Closed Bug 1570251 Opened 2 years ago Closed 2 years ago

Address bar input field and autocomplete results list don't line up anymore

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox69 --- unaffected
firefox70 --- wontfix

People

(Reporter: dao, Assigned: nhnt11)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1548198 +++

I believe bug 1569182 regressed this.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1570008

According to bug 1570008 comment 23, it seems that this isn't fully fixed yet.

Status: RESOLVED → REOPENED
Depends on: 1570008
Regressed by: 1567185
Resolution: DUPLICATE → ---
Whiteboard: [privacy-panel][skyline]

Removing priority so that this shows up in our triage...

Priority: P2 → --
Attached image actual.png

From Comment 23 of bug 1570008:

It looks like the Text input needs to be shifted 2px to the left when the proxy state is valid. That would look much more balanced with the other spacings in the Address Bar and be aligned again with the Drop Down text.

Attached image expected.png
See Also: → 1570663

please see also bug 1570663. I suspect there's some relation

Tim, could you please look at this and bug 1570663?

Flags: needinfo?(tihuang)

Sure.

Flags: needinfo?(tihuang)

I am wondering one thing here. If we change to align the awesome bar to the shield icon in Bug bug 1570663, do we still care about to align input text when the awesome bar is shown by the dropdown button? There will be a gap between the text in the awesome bar and the input text anyway in this case and this matches the old behavior, per Bug 1570663 comment 4, when there were an "i" icon and the lock icon on the url bar. So, maybe we don't need to align the text if using the dropdown button?

Flags: needinfo?(adw)
Status: REOPENED → NEW

That's what I needinfo'ed verdi on. I'll ping him again. But probably we should just do what we were doing, align the icons with the shield (which took the place of the "i") and not align the text.

Flags: needinfo?(adw)
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Priority: -- → P1

Is there still anything left to do here? Sorry to bug you Drew, but I can't tell for sure if other changes have fixed this bug at this point. Could you help? If there's something to be done I am happy to write the patch.

Flags: needinfo?(adw)

Hi Nihanth, no problem. Thanks for following up. This appears to be fixed!

Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(adw)
Resolution: --- → WORKSFORME

There is bug 1575441 though, sigh...

See Also: → 1575441

(In reply to Drew Willcoxon :adw from comment #13)

Hi Nihanth, no problem. Thanks for following up. This appears to be fixed!

Please consider Bug 1578093. Thanks :)

You need to log in before you can comment on or make changes to this bug.