Closed Bug 1570279 Opened 3 months ago Closed 3 months ago

Bug 1508287 disabled some checks in test_objectgrips-17.js

Categories

(DevTools :: Debugger, defect, P3)

65 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 fixed, firefox68 wontfix, firefox69 fixed, firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: Oriol, Assigned: Oriol)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Bug 1508287 refactored test_objectgrips-17.js

When I wrote the test, I used null to refer to a NullPrincipal. But after the refactoring, debuggeePrincipal is a NullPrincipal object.

Therefore, this conditional never runs:

  if (debuggeePrincipal === null) {
    // Test objects created in a same-origin null principal new global.
    await testPrincipal(
      options,
      Cu.getObjectPrincipal(debuggee),
      debuggeeHasXrays
    );
  }

Also, just fixing the condition is not enough, because threadFrontTest ignores the wantXrays parameter.

Priority: -- → P3
Keywords: checkin-needed

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/09384c51f127
Reenable accidentally disabled checks in test_objectgrips-17.js. r=ochameau
https://hg.mozilla.org/integration/mozilla-inbound/rev/7acf0e8d6a66
Some refactoring for test_objectgrips-17.js. r=ochameau

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.