Closed Bug 1570336 Opened 2 months ago Closed 2 months ago

Startup delay in badging toolbar elements

Categories

(Firefox :: Messaging System, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox70 --- fixed

People

(Reporter: andreio, Assigned: andreio)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [skyline][uj])

Attachments

(1 file)

While landing bug 1561547 there were several performance issues around flickering.
Because of the overhead of starting ActivityStream, ASRouter and only then evaluating the messages there is a slowdown of 1-2s.

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Assignee: nobody → andrei.br92
Iteration: --- → 70.2 - Jul 22 - Aug 4
Priority: -- → P1
Iteration: 70.2 - Jul 22 - Aug 4 → 70.3 - Aug 5 - 18
Whiteboard: [skyline][uj]
See Also: → 1574149
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/adba66fff09b
Add exception to test rather than disabling the feature for all performance tests r=mconley
Regressions: 1574260
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.