Closed Bug 1570476 Opened 4 months ago Closed 3 months ago

Intermittent devtools/client/webconsole/test/mochitest/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | A promise chain failed to handle a rejection: 'getStackTrace' active request packet to 'server0.conn296.netEvent4' can

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 wontfix, firefox69 wontfix, firefox70 wontfix, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=259200489&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/apCpbHeeSXK9LogkHIswZg/runs/0/artifacts/public/logs/live_backing.log


task 2019-07-31T16:22:08.894Z] 16:22:08 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | Network message found. -
[task 2019-07-31T16:22:08.894Z] 16:22:08 INFO - Expand the network message
[task 2019-07-31T16:22:08.900Z] 16:22:08 INFO - Click on XHR message and wait for the network detail panel to be displayed
[task 2019-07-31T16:22:08.900Z] 16:22:08 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | StackTrace tab is available -
[task 2019-07-31T16:22:08.900Z] 16:22:08 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | There's the expected frames -
[task 2019-07-31T16:22:08.900Z] 16:22:08 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | The stacktrace does not have devtools' internal frames -
[task 2019-07-31T16:22:08.900Z] 16:22:08 INFO - Leaving test bound task
[task 2019-07-31T16:22:08.900Z] 16:22:08 INFO - Buffered messages logged at 16:22:08
[task 2019-07-31T16:22:08.902Z] 16:22:08 INFO - Removing tab.
[task 2019-07-31T16:22:08.902Z] 16:22:08 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-07-31T16:22:08.903Z] 16:22:08 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-07-31T16:22:08.903Z] 16:22:08 INFO - Tab removed and finished closing
[task 2019-07-31T16:22:08.903Z] 16:22:08 INFO - Console message: [JavaScript Error: "uncaught exception: Object"]
[task 2019-07-31T16:22:08.903Z] 16:22:08 INFO - Console message: [JavaScript Error: "Error: Error while calling method getStackTrace: 'getStackTrace' active request packet to 'server0.conn296.netEvent4' can't be sent as the connection just closed." {file: "resource://devtools/client/netmonitor/src/connector/firefox-data-provider.js" line: 615}]
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - Buffered messages finished
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | A promise chain failed to handle a rejection: 'getStackTrace' active request packet to 'server0.conn296.netEvent4' can't be sent as the connection just closed. - stack: listenerJson@resource://devtools/shared/client/debugger-client.js:342:11
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - emit@resource://devtools/shared/event-emitter.js:190:24
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - emit@resource://devtools/shared/event-emitter.js:271:18
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - reject@resource://devtools/shared/client/debugger-client.js:816:15
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - purgeRequests/<@resource://devtools/shared/client/debugger-client.js:837:47
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - purgeRequests@resource://devtools/shared/client/debugger-client.js:837:28
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - onClosed@resource://devtools/shared/client/debugger-client.js:763:10
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - close@resource://devtools/shared/transport/local-transport.js:171:20
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - close@resource://devtools/shared/transport/local-transport.js:167:13
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - close@resource://devtools/shared/transport/local-transport.js:167:13
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - cleanup@resource://devtools/shared/client/debugger-client.js:216:27
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - close/promise<@resource://devtools/shared/client/debugger-client.js:232:7
[task 2019-07-31T16:22:08.904Z] 16:22:08 INFO - close@resource://devtools/shared/client/debugger-client.js:209:21
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - TargetMixin/destroy/this._destroyer<@resource://devtools/shared/fronts/targets/target-mixin.js:581:32
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - asyncdestroy@resource://devtools/shared/fronts/targets/target-mixin.js:604:9
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - destroy@resource://devtools/shared/fronts/targets/browsing-context.js:148:27
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - _destroyToolbox/onceDestroyed</<@resource://devtools/client/framework/toolbox.js:3626:27
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - async
_destroyToolbox/onceDestroyed<@resource://devtools/client/framework/toolbox.js:3585:12
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - _destroyToolbox@resource://devtools/client/framework/toolbox.js:3581:27
[task 2019-07-31T16:22:08.905Z] 16:22:08 INFO - destroy@resource://devtools/client/framework/toolbox.js:3457:28

There are 23 total failures in the last 7 days: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-09-05&endday=2019-09-12&tree=trunk&bug=1570476

Recent failure log : https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=266246240&repo=autoland&lineNumber=34356

[task 2019-09-12T07:33:13.334Z] 07:33:13 INFO - TEST-START | devtools/client/webconsole/test/browser/browser_webconsole_network_messages_stacktrace_console_initiated_request.js
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_network_messages_stacktrace_console_initiated_request.js | A promise chain failed to handle a rejection: 'getStackTrace' active request packet to 'server0.conn214.netEvent4' can't be sent as the connection just closed. - stack: listenerJson@resource://devtools/shared/client/debugger-client.js:341:17
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - emit@resource://devtools/shared/event-emitter.js:190:24
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - emit@resource://devtools/shared/event-emitter.js:271:18
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - reject@resource://devtools/shared/client/debugger-client.js:815:15
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - purgeRequests/<@resource://devtools/shared/client/debugger-client.js:836:53
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - purgeRequests@resource://devtools/shared/client/debugger-client.js:836:28
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - onClosed@resource://devtools/shared/client/debugger-client.js:762:10
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - close@resource://devtools/shared/transport/local-transport.js:171:20
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - close@resource://devtools/shared/transport/local-transport.js:167:13
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - close@resource://devtools/shared/transport/local-transport.js:167:13
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - cleanup@resource://devtools/shared/client/debugger-client.js:215:27
[task 2019-09-12T07:33:19.555Z] 07:33:19 INFO - close/promise<@resource://devtools/shared/client/debugger-client.js:231:7
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - close@resource://devtools/shared/client/debugger-client.js:208:21
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - TargetMixin/destroy/this._destroyer<@resource://devtools/shared/fronts/targets/target-mixin.js:457:32
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - asyncdestroy@resource://devtools/shared/fronts/targets/target-mixin.js:480:9
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - destroy@resource://devtools/shared/fronts/targets/browsing-context.js:148:27
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - _destroyToolbox/onceDestroyed</<@resource://devtools/client/framework/toolbox.js:3634:27
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - promise callback
_destroyToolbox/onceDestroyed<@resource://devtools/client/framework/toolbox.js:3591:12
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - _destroyToolbox@resource://devtools/client/framework/toolbox.js:3587:27
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - destroy@resource://devtools/client/framework/toolbox.js:3463:28
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - closeToolbox@resource://devtools/client/framework/devtools.js:673:19
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - asynccloseTabAndToolbox@chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:500:23
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - async
cleanup@chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:161:11
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - nextTest@chrome://mochikit/content/browser-test.js:860:35
[task 2019-09-12T07:33:19.556Z] 07:33:19 INFO - async*testScope/test_finish/<@chrome://mochikit/content/browser-test.js:1732:25
[task 2019-09-12T07:33:19.557Z] 07:33:19 INFO - run@chrome://mochikit/content/browser-test.js:1647:9
[task 2019-09-12T07:33:19.557Z] 07:33:19 INFO - Rejection date: Thu Sep 12 2019 07:33:19 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 263

Nicolas, could you assign this to someone?

Flags: needinfo?(nchevobbe)
Whiteboard: [stockwell needswork:owner]

Yes, let me have a look

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Flags: needinfo?(nchevobbe)

This was causing an intermittent in console test because
multiple requests were sent to the server, and sometimes,
some of them after the connection being closed, which
was making the test fail.
With this patch, we only try to fetch a new stacktrace
on componenetWillReceiveProps if the component will have
to deal with a new request.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfc5a1ad7e10
Don't fetch the request stacktrace in StackTracePanel's componentWillReceiveProps if the request won't change. r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.