Closed Bug 1570544 Opened 4 months ago Closed 4 months ago

Permafailing tier 2 font-matching/emoji-fallback-1.html == font-matching/emoji-fallback-1-ref.html | image comparison, max difference: 242, number of differing pixels: 3578

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jnicol)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=259308230&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/MiIILZQARh2XP0wYwuODJA/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/MiIILZQARh2XP0wYwuODJA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST TEST-START | http://10.7.205.201:8854/tests/layout/reftests/font-matching/emoji-fallback-1.html == http://10.7.205.201:8854/tests/layout/reftests/font-matching/emoji-fallback-1-ref.html
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST INFO | RESTORE PREFERENCE pref(gfx.font_loader.delay,8000)
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST INFO | SET PREFERENCE pref(gfx.font_loader.delay,0)
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST TEST-LOAD | http://10.7.205.201:8854/tests/layout/reftests/font-matching/emoji-fallback-1.html | 1194 / 1950 (61%)
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST INFO | RESTORE PREFERENCE pref(gfx.font_loader.delay,8000)
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST INFO | SET PREFERENCE pref(gfx.font_loader.delay,0)
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST TEST-LOAD | http://10.7.205.201:8854/tests/layout/reftests/font-matching/emoji-fallback-1-ref.html | 1194 / 1950 (61%)
[task 2019-08-01T01:32:08.088Z] 01:32:08 INFO - REFTEST TEST-UNEXPECTED-FAIL | http://10.7.205.201:8854/tests/layout/reftests/font-matching/emoji-fallback-1.html == http://10.7.205.201:8854/tests/layout/reftests/font-matching/emoji-fallback-1-ref.html | image comparison, max difference: 242, number of differing pixels: 3578

Flags: needinfo?(jnicol)
Regressed by: 1562316

This has started permafailing once Bug 1562316 has landed.
Jamie, could you please take a look?
Thank you.

These tests were marked as fails-if(geckoview&&!webrender). They are failing on geckoview because of bug 1558513: there is an offset between the emojis in test and reference images.

The reason that they were passing on webrender previously was because the emojis weren't being drawn at all, so both the test and reference images were blank. Bug 1562316 fixed the emojis being drawn with webrender, but bug 1558513 remains (they are still offset).

So I will update the test annotation to simply fails-if(geckoview).

Flags: needinfo?(jnicol)
See Also: → 1558513
Assignee: nobody → jnicol

These tests were marked as fails-if(geckoview&&!webrender). They are
failing on geckoview because of bug 1558513: there is an offset
between the emojis in the test and reference images.

The reason that they were passing on webrender previously was because
the emojis weren't being drawn at all, so both the test and reference
images were blank. Bug 1562316 fixed the emojis being drawn with
webrender, but bug 1558513 remains (they are still offset).

Pushed by jnicol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c000d823932
Mark emoji reftests as failing for geckoview (regardless of webrender) r=lsalzman
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.