All users were logged out of Bugzilla on October 13th, 2018

DOMCharacterDataModified does not properly reflect newValue when pasting text in a <textarea>

VERIFIED DUPLICATE of bug 117131

Status

()

VERIFIED DUPLICATE of bug 117131
17 years ago
16 years ago

People

(Reporter: jasonkarldavis, Assigned: joki)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
See the URL for a testcase.

I alert [event.prevValue, event.newValue] everytime DOMCharacterDataModified is
fired on the textarea. Pasting text in fires the event, but both properties are
equal to ''.

I feel newValue should be whatever the final value of the textarea is.
(Reporter)

Comment 1

17 years ago
Bah, forgot the obvious build number.

It exhibits the (incorrect?) behavior in build 2002071509

Comment 2

17 years ago
newValue works for me but prevValue is not set...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
its a dupe..

*** This bug has been marked as a duplicate of 117131 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.