Closed Bug 1570586 Opened 6 months ago Closed 6 months ago

help menu links won't open

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(thunderbird_esr6868+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 68+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: mkmelin, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

I messed this up in bug 1567103 :(
event.button is mostly undefined so the links won't open

Attachment #9082189 - Flags: review?(jorgk)
Comment on attachment 9082189 [details] [diff] [review]
bug1570586_help_links_broken.patch

Yes, all the items on the Help menu apart from Help don't work, and the patch fixes that. I was looking at the links in the about menu which all work, but I wondered what this change was about:
https://hg.mozilla.org/comm-central/rev/dcddacbba74a#l3.12
Attachment #9082189 - Flags: review?(jorgk)
Attachment #9082189 - Flags: review+
Attachment #9082189 - Flags: approval-comm-esr68?
Attachment #9082189 - Flags: approval-comm-beta?
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

Please choose a commit message that expresses what you did, a mention of a regressing bug can also be helpful. You had: "help menu links won't open" which is the bug summary which is rarely useful as a commit message. Also see:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch
They suggest:
Bug 123456 - Change this thing to work better by doing something. r=reviewers

I change commit messages all the time, and I wish I could reduce this activity ;-)

Target Milestone: --- → Thunderbird 70.0
Version: unspecified → 69

I think many times changing the hg message to something besides the bug summary is not actually very helpful. It's pretty obvious that the patch is fixing the mentioned bug, so prepending the comment with "fixing" or something of the like is not gaining much.

Hmm, you disagree with the Mozilla guidelines?

The text of the message should be what you did to fix the bug, not a description of what the bug was. If it is not obvious why this change is appropriate, then explain why in the commit message. If this does not fit on one line, then leave a blank line and add further lines for more detail and/or reasoning.

To a degree yes, it depends on the bug. I do see commit messages getting less descriptive when you try to water it down to the low level actual change was (just describing the technical change, which you could just see from the code). Many times the symptoms are a very important part of what you fixed, and a message like "fix newline handling in some message processing" is way less informative than that the bug happens especially for a certain server. Of course you could argue for the commit message to contain both...

Well, I think "fix help menu links after bug 1567103" is pretty good, it could have been "fix help menu links after bug 1567103 by not accessing bull event".

In general, I agree that something like "do this to fix that" or "fix this by doing that" is preferable, but you only have this much space. Listing the low-level change without any reference to the issue is of course not productive.

Something like this is ideal:
Khushil Mistry - Bug 1569399 - openConversationButton.tooltip changed to openMsgConversationButton.tooltip for messenger.dtd to fix duplication. r=jorgk
Jorg K - Bug 1569399 - Move chat.dtd after messenger.dtd in messenger.xul to work around duplicate string issue. r=khushil
Richard Marti - Bug 1567371 - Port bug 1493844, subdialogs.js part, to fix connection settings subdialog. r=jorgk
Bug 1556203 - Fix context menu for chat by hand-rolling it, also use correct spellcheck dictionary. r=aceman

Attachment #9082189 - Flags: approval-comm-esr68?
Attachment #9082189 - Flags: approval-comm-esr68+
Attachment #9082189 - Flags: approval-comm-beta?
Attachment #9082189 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.