Closed Bug 1570604 Opened 5 years ago Closed 5 years ago

Rename DebuggerClient.getActor to getFront

Categories

(DevTools :: Framework, task, P3)

task

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

DebuggerClient exposes a method to retrieve the Front (or client if we still have some) for a given actor whose ID is passed as argument:
https://searchfox.org/mozilla-central/source/devtools/shared/client/debugger-client.js#926-929

This naming is surprising as you would expect to retrieve an Actor instance.

This work relates to bug 1478973, where we do expose get and actor to retrieve something from a Pool. In that bug, we would like to get rid of the too generic get method.
But that would mean that here, in debugger-client.js, we would have to call
pool.actor(actorID). Should we then have both actor and a front methods?
The confusion comes from the fact that Pool is used by both client and server side...

Assignee: nobody → poirot.alex
Type: enhancement → task
Priority: -- → P3

In the current patch, I renamed it to getFront in place of getActor, but may be that would be cleared if we name it getFrontById in order to distinguish from TargetMixin.getFront, which accept a typeName instead of an ID?

Attachment #9083258 - Attachment description: Bug 1570604 - Rename DebuggerClient.getActor to getFront. → Bug 1570604 - Rename DebuggerClient.getActor to getFrontByID.
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/598aa6ad2c74
Rename DebuggerClient.getActor to getFrontByID. r=jdescottes,yulia
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: