filename with intl chars (�дц� etc.) doesn't show up in download manager

VERIFIED FIXED

Status

SeaMonkey
Download & File Handling
--
major
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: peter, Assigned: janv)

Tracking

({intl})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Reporter)

Description

16 years ago
i tried Bugzilla Bug 154760 on build 2002071108 -> problem resolved.. BUT
the file entry in the download manager is empty..! no name, no size.. nothing.. 
i can't even delete it...
This happens because of bug 132905 comment 45: NS_ConvertUTF8toUCS2 gives an
empty string when the input is not UTF8.

Now who's calling NS_ConvertUTF8toUCS2 with bogus data?

Comment 2

16 years ago
*** Bug 160952 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Confirming based on the dup.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Keywords: intl
Summary: filename with צה etc. doesn't show up in download manager → filename with national chars (צה�טר etc.) doesn't show up in download manager

Comment 4

16 years ago
I'm still on build 2002053012 (Win2k), click on link and then select "Save this
file to disk" return an empty filename (just the extension), but r-click to
select "Save link target as..." return the filename with %xx codes in place of
space and "foreing" chars (see url with 2 sample files to download).

http://www.netsolution.cl/mt/test/

Comment 5

16 years ago
Checked on build 2002081612 (Win98), everything work fine (Save file and Save
link target).

(Files still there if anyone interesed)

Comment 6

16 years ago
Confirming the bug on Mozilla 1.1 / WinNT4 :
when saving a downloaded file to a local directory containing non-ASCII characters.

Exemple : Dwonloading "myzip.zip" to "D:\Download\Java\Outils de développement".
In the file download.rdf in the profile, the tag RDF:li of the download is wrong: 
<RDF:li resource="D:\Download\Java\Outils de deloppement\myzip.zip"/>
There is the same problem in filenames in the <RDF:Seq about="NC:DownloadsRoot">
section.

"deloppement" is not "développement".

The consequence of this is that the download manager window is completely
broken.  There is some empty lines, removing those lines doesn't work...


This seems to be an UTF-8 conversion problem. The filename returned by the
Windows open dialog is not tranlated to UTF-8 before submitting the filename to
the Download manager.

Comment 7

15 years ago
confirming with Mozilla 1.2a on Win NT 4.0
UA: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2a) Gecko/20020910
Build ID: 2002091014
QA Contact: sairuh → ruixu
Summary: filename with national chars (צה�טר etc.) doesn't show up in download manager → filename with intl chars (צה�טר etc.) doesn't show up in download manager

Comment 8

15 years ago
Could we please change this bug's severity to Major? On my Greek Windows 98 it
is very annoying: Even the Desktop has a greek path name ("C:\Windows\&#917;&#960;&#953;&#966;&#940;&#957;&#949;&#953;&#945;
&#917;&#961;&#947;&#945;&#963;&#943;&#945;&#962;") and thus whenever I save a file on the desktop I get an empty,
non-deletable entry in the Download Manager...

Is this a duplicate of bug 171834 ?

Updated

15 years ago
QA Contact: ruixu → ylong
Summary: filename with intl chars (צה�טר etc.) doesn't show up in download manager → filename with intl chars (צהװזצ etc.) doesn't show up in download manager

Comment 9

15 years ago
*** Bug 171834 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
OS -> All
Severity -> major
Severity: normal → major
OS: Windows 2000 → All
Hardware: PC → All

Comment 11

15 years ago
*** Bug 174809 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Depends on: 155429

Comment 12

15 years ago
*** Bug 173385 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
Nominating for buffy. This needs a fix, although I'm not entirely sure if 
this is download manager, per se. Perhaps an RDF or i18n issue?
Keywords: nsbeta1

Comment 14

15 years ago
tested on 2002-11-14-07-1.0
Redhat 7.3 
No problem to download and display download manager using �«¢�«®�«¢ as file name. 
File types are gif and html. 
Summary: filename with intl chars (צהװזצ etc.) doesn't show up in download manager → filename with intl chars (&#65533;дц&#65533; etc.) doesn't show up in download manager

Updated

15 years ago
Summary: filename with intl chars (&#65533;дц&#65533; etc.) doesn't show up in download manager → filename with intl chars (צהװזצ etc.) doesn't show up in download manager

Comment 15

15 years ago
Nav triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]

Comment 16

15 years ago
Nav triage team: bumping up to adt2.
Whiteboard: [adt3] → [adt2]

Comment 17

15 years ago
WFM 2003111412-trunk/Linux build.

But cannot 'Remove from list' the line
which has Japanese file name.
Is it another bug?
(Assignee)

Comment 18

15 years ago
reassigning
Assignee: blaker → varga
Depends on: 189301

Comment 19

15 years ago
WFM with builds 2003012208 and 2003012304 under Win NT4 (German).

This bug seems to be fixed by the patch to bug 189301.

Comment 20

15 years ago
Fixed by bug 189301.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Summary: filename with intl chars (צהװזצ etc.) doesn't show up in download manager → filename with intl chars (&#65533;дц&#65533; etc.) doesn't show up in download manager

Comment 21

15 years ago
*** Bug 192298 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
*** Bug 195202 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
Thanks, I got 1.3b it's ok. Sorry for dublicate, I've searched before report but
didn't find it.

Comment 24

15 years ago
Verified..
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.