Closed Bug 1570644 Opened 2 months ago Closed 28 days ago

Disable LSNG in 69

Categories

(Core :: DOM: Web Storage, task, P1, major)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 blocking fixed
firefox70 --- unaffected

People

(Reporter: hsinyi, Assigned: janv)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(4 files)

We're working on a fix due to bug 1560697 and we've decided to disable LSNG in 69.

Assignee: nobody → jvarga
Status: NEW → ASSIGNED
Priority: -- → P1
See Also: → 1562942
See Also: → 1560697

Comment on attachment 9083285 [details]
Bug 1570644 - Part 4: Disable LSNG in 69; r=asuth

Beta/Release Uplift Approval Request

  • User impact if declined: If LSNG is enabled, quota manager storage initialization time is increased by ~30%
    We don't want to ship LSNG until this regression is fixed.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch just disables LSNG, so the old implementation of LocalStorage will be used in FF 69. We fully support downgrading of LocalStorage data, so if some users already tried a beta build, they should be safe. We actually disabled LSNG in previous beta cycles and there were no problems reported after the switch.
  • String changes made/needed: None
Attachment #9083285 - Flags: approval-mozilla-beta?

Comment on attachment 9083285 [details]
Bug 1570644 - Part 4: Disable LSNG in 69; r=asuth

Uplift approved for 69 beta 12, thanks.

Attachment #9083285 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Backed out for various localstorage related failures, e.g. in dom/tests/browser/browser_localStorage_e10s.js:

https://hg.mozilla.org/releases/mozilla-beta/rev/8055f364e2cc60f0f721ec2694f684b715a2c037

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&selectedJob=260447733&resultStatus=usercancel%2Ctestfailed%2Cbusted%2Cexception&revision=440c7ba936c5a5344ecd5be2801f1e8da229d361
Please check all failed jobs.
Failure log for dom/tests/browser/browser_localStorage_e10s.js: https://treeherder.mozilla.org/logviewer.html#?job_id=260447733&repo=mozilla-beta
TEST-UNEXPECTED-FAIL | dom/tests/browser/browser_localStorage_e10s.js | Uncaught exception - at resource://specialpowers/SpecialPowersAPIParent.jsm:22 - SpecialPowersError: Unrecognized Special Powers API: Wakeup

Status: RESOLVED → REOPENED
Flags: needinfo?(jvarga)
Resolution: FIXED → ---

Marking this uplift as a blocker as we don't want to ship without it in 69.

I'm verifying a patch here:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e3d7fe0f334687c45a1143fca0d132528eb1a7b4

There's still some work and this will require a new review, should be ready soon.

Flags: needinfo?(jvarga)
Regressed by: 1556812
Regressed by: 1541557
Regressed by: 1551055
Attachment #9083285 - Attachment description: Bug 1570644 - Disable LSNG in 69; r=asuth → Bug 1570644 - Part 4: Disable LSNG in 69; r=asuth

Part 1, 2, 3 need to get r+ and land on m-c first.

Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/60cb55ea9f2a
Part 1: Fix a regression caused by bug 1556812; r=asuth
https://hg.mozilla.org/integration/autoland/rev/7aa755add6a0
Part 2: Fix a regression caused by bug 1541557 part 7; r=asuth
https://hg.mozilla.org/integration/autoland/rev/6ead2cb63757
Part 3: Fix a regression caused by bug 1551055 part 1; r=asuth
Status: REOPENED → RESOLVED
Closed: Last month28 days ago
Resolution: --- → FIXED
Target Milestone: mozilla69 → mozilla70

To be clear, only the support patches landed on m-c for Fx70. The actual disabling of LSNG only landed on Beta. Updating the flags to better reflect that.

Target Milestone: mozilla70 → mozilla69
You need to log in before you can comment on or make changes to this bug.