Closed Bug 1570816 Opened 8 months ago Closed 8 months ago

Hit MOZ_CRASH(assertion failed: `(left == right)` left: `Nearest`, right: `Linear`) at gfx/wr/webrender/src/texture_cache.rs:304

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: tsmith, Assigned: kvark)

References

(Blocks 2 open bugs, Regression)

Details

(4 keywords)

Crash Data

Attachments

(2 files)

Attached file testcase.html

Reduced with m-c:
BuildID=20190731215544
SourceStamp=b0124f06562982dce60b820d95aad23afd5cec90

Hit MOZ_CRASH(assertion failed: `(left == right)` left: `Nearest`, right: `Linear`) at gfx/wr/webrender/src/texture_cache.rs:304
#0 MOZ_Crash(char const*, int, char const*) src/obj-firefox/dist/include/mozilla/Assertions.h:313:3
#1 GeckoCrash src/toolkit/xre/nsAppRunner.cpp:5154
#2 gkrust_shared::panic_hook::h7e8be19f063b0702 src/toolkit/library/rust/shared/lib.rs:247:8
#3 core::ops::function::Fn::call::h91a81df8c7b006ff /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libcore/ops/function.rs:69:4
#4 std::panicking::rust_panic_with_hook::h096dff2cb12b67ce /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/panicking.rs:481:16
#5 std::panicking::continue_panic_fmt::h0046167652be99a6 /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/panicking.rs:384:4
#6 std::panicking::begin_panic_fmt::he65a2e8ff19d8ae0 /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/panicking.rs:339:4
#7 webrender::texture_cache::SharedTextures::select::h5a92d92ef518e0ff src/gfx/wr/webrender/src/texture_cache.rs
#8 webrender::texture_cache::TextureCache::allocate_from_shared_cache::hadfa6e034e945b4b src/gfx/wr/webrender/src/texture_cache.rs:1158:39
#9 webrender::texture_cache::TextureCache::allocate_cache_entry::h49e5bcc354513191 src/gfx/wr/webrender/src/texture_cache.rs:1264:29
#10 webrender::texture_cache::TextureCache::allocate::h60c0a0698f8ec072 src/gfx/wr/webrender/src/texture_cache.rs:1368
#11 webrender::texture_cache::TextureCache::update::h36a6a499fb1f1496 src/gfx/wr/webrender/src/texture_cache.rs:931
#12 webrender::resource_cache::ResourceCache::update_texture_cache::h7024e99a2e8f06e6 src/gfx/wr/webrender/src/resource_cache.rs:1750:16
#13 webrender::resource_cache::ResourceCache::block_until_all_resources_added::h878855cea24a9bfd src/gfx/wr/webrender/src/resource_cache.rs:1609
#14 webrender::frame_builder::FrameBuilder::build_layer_screen_rects_and_cull_layers::hdfea10de888caaf2 src/gfx/wr/webrender/src/frame_builder.rs:497:12
#15 webrender::frame_builder::FrameBuilder::build::h4c4746c70b0419a7 src/gfx/wr/webrender/src/frame_builder.rs:553
#16 webrender::render_backend::Document::build_frame::he38360263cfdddc4 src/gfx/wr/webrender/src/render_backend.rs:537:24
#17 webrender::render_backend::RenderBackend::update_document::hb072f161eecd5775 src/gfx/wr/webrender/src/render_backend.rs:1495:40
#18 webrender::render_backend::RenderBackend::prepare_transactions::h9f116ff4b2958ea4 src/gfx/wr/webrender/src/render_backend.rs:1327:16
#19 webrender::render_backend::RenderBackend::process_api_msg::h699b6020f6612fee src/gfx/wr/webrender/src/render_backend.rs:1219
#20 webrender::render_backend::RenderBackend::run::h40387d8d2a2dd11e src/gfx/wr/webrender/src/render_backend.rs:970:20
#21 webrender::renderer::Renderer::new::_$u7b$$u7b$closure$u7d$$u7d$::h38d8a097cf229f26 src/gfx/wr/webrender/src/renderer.rs:2198:12
#22 std::sys_common::backtrace::__rust_begin_short_backtrace::heeebb499955bc092 /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/sys_common/backtrace.rs:77
#23 std::thread::Builder::spawn_unchecked::_$u7b$$u7b$closure$u7d$$u7d$::_$u7b$$u7b$closure$u7d$$u7d$::h1e5fabe328f25df1 /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/thread/mod.rs:470:16
#24 _$LT$std..panic..AssertUnwindSafe$LT$F$GT$$u20$as$u20$core..ops..function..FnOnce$LT$$LP$$RP$$GT$$GT$::call_once::hf5bc1e9213f1ad44 /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/panic.rs:315
#25 std::panicking::try::do_call::h9e7ae85612cfef27 (.llvm.13472802016345216293) /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libstd/panicking.rs:296
#26 __rust_maybe_catch_panic /rustc/61d1607e0f6a18bb4897d6f9b10abeac9e11eb8e/src/libpanic_abort/lib.rs:29:4
Flags: in-testsuite?
Crash Signature: [@ webrender::texture_cache::SharedTextures::select ]

mozregression --good 2019-06-01 --bad 2019-07-31 -B debug --pref gfx.webrender.all:true -a https://bugzilla.mozilla.org/attachment.cgi?id=9082481

14:49.37 INFO: Last good revision: ce76fa05c90f3f24f8db09950eadd4a8cdec9088
14:49.37 INFO: First bad revision: bc58681d24079ae0bdb65c9679455042dccf0e76
14:49.37 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ce76fa05c90f3f24f8db09950eadd4a8cdec9088&tochange=bc58681d24079ae0bdb65c9679455042dccf0e76

bc58681d24079ae0bdb65c9679455042dccf0e76 Dzmitry Malyshau — Bug 1548339 - WR swizzle configuration of texture units r=gw

Has Regression Range: --- → yes
Flags: needinfo?(dmalyshau)
Keywords: regression
Regressed by: 1548339

Thank you! That looks like an easy to fix bug. Will look as the first thing tomorrow.

Assignee: nobody → dmalyshau
Status: NEW → ASSIGNED
Flags: needinfo?(dmalyshau)
Pushed by dmalyshau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e89d0ddd5e42
Disallow nerest-sampled alpha textures in the shared cache in WR r=gw
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.