Autocomplete advanced window too small if none of the checkboxes are checked

VERIFIED FIXED in mozilla1.1beta

Status

SeaMonkey
Preferences
P3
normal
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: sicking, Assigned: Christopher Aillon (sabbatical, not receiving bugmail))

Tracking

Trunk
mozilla1.1beta

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Steps to reproduce:

1. Go to Preferences->Navigator->Smart Browsing
2. Click "Advanced..."
3. Uncheck *all* checkboxes
4. Restart browser
5. Go to Preferences->Navigator->Smart Browsing
6. Click "Advanced..."

The advanced dialog will now be too small
Status: NEW → ASSIGNED
OS: Windows 2000 → All
Priority: -- → P3
Target Milestone: --- → mozilla1.1beta
I've got a patch for this which I'll upload shortly.
Created attachment 91163 [details] [diff] [review]
Fix v1

So what happens is when no items are checked, our vbox initially starts out
with an image with no src attribute, and 2 hidden images since we end up hiding
them via JS.  We then apply the image src after we load the page, but by then
the dialog is already sized wrongly.  Placing an explicit min-width style here
will work.  The image is 401px wide so that's what I set min-width to.

Comment 4

16 years ago
Comment on attachment 91163 [details] [diff] [review]
Fix v1

sr=blake
Attachment #91163 - Flags: superreview+

Comment 5

16 years ago
Comment on attachment 91163 [details] [diff] [review]
Fix v1

a=asa (on behalf of drivers) for checkin to the 1.1 trunk.
Attachment #91163 - Flags: approval+

Comment 6

16 years ago
*** Bug 102692 has been marked as a duplicate of this bug. ***
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
vrfy'd fixed with 2002.09.16.08 comm trunk builds.
Status: RESOLVED → VERIFIED
Hardware: PC → All
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.