Closed Bug 1570846 Opened 2 years ago Closed 2 years ago

Switch permissionsManager and cookieViewer to use Services.jsm

Categories

(SeaMonkey :: Passwords & Permissions, task)

task
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.67
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.1)

Attachments

(2 files, 2 obsolete files)

As we still have cookieViewer and permissionsManager around we should switch them to fully use Services.jsm
Added a helper function for prompt service confirmation dialogs in cookieViewer so not repeating the same code in 4 places and removed the orphaned gDateService.

Attached patch Switch to use Services.jsm (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9082512 - Flags: review?(frgrahl)
Attachment #9082512 - Flags: approval-comm-release?
Attachment #9082512 - Flags: approval-comm-esr60?
Attached patch Switch to use Services.jsm v1.1 (obsolete) — Splinter Review

As frg pointed out I missed the nsI* in the linked xul files - fixed.

Attachment #9082512 - Attachment is obsolete: true
Attachment #9082512 - Flags: review?(frgrahl)
Attachment #9082512 - Flags: approval-comm-release?
Attachment #9082512 - Flags: approval-comm-esr60?
Attachment #9082659 - Flags: review?(frgrahl)
Attachment #9082659 - Flags: approval-comm-release?
Attachment #9082659 - Flags: approval-comm-esr60?
Comment on attachment 9082659 [details] [diff] [review]
Switch to use Services.jsm v1.1

r/a+
Attachment #9082659 - Flags: review?(frgrahl)
Attachment #9082659 - Flags: review+
Attachment #9082659 - Flags: approval-comm-release?
Attachment #9082659 - Flags: approval-comm-release+
Attachment #9082659 - Flags: approval-comm-esr60?
Attachment #9082659 - Flags: approval-comm-esr60+

Equivalent version for c-c, carrying forward r+

Attachment #9083711 - Flags: review+

Rebased so that patch from bug 1209626 can be applied on top.
Carrying forward r/a

Attachment #9082659 - Attachment is obsolete: true
Attachment #9084529 - Flags: review+
Attachment #9084529 - Flags: approval-comm-release+
Attachment #9084529 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/1e66494caeb1
Switch permissionsManager and cookieViewer to use Services.jsm. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.