Closed Bug 1570880 (fennec-new-tab-signin) Opened 4 months ago Closed Last month

Add sign-in button and status to Fennec New Tab

Categories

(Firefox for Android :: Awesomescreen, enhancement, P1)

Unspecified
Android
enhancement

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 70+ verified
firefox68 --- wontfix
firefox69 --- affected
firefox70 --- affected

People

(Reporter: cpeterson, Assigned: vlad.baicu)

References

(Depends on 1 open bug)

Details

(Whiteboard: [fennec68.2])

Attachments

(2 files)

Project plan: https://docs.google.com/document/d/1njMzQ4NGCN___ms2a2dkgVC4fi1OkWIaqxp3Y-vZLYw/edit
PI request: https://jira.mozilla.com/browse/PI-228

  1. Add a card to the new tab page prompting account sign in.
  2. Card is dynamic and shows either a place to sign in or current signed in status.
  3. There’s an X to dismiss card.

We will need L10n for new UI strings.

Even before the final UX we'll need the new strings to allow localizers as much time as possible to translate them.
Based on

  1. Card is dynamic and shows either a place to sign in or current signed in status.

I understand there are more strings involved than just "Sign in" .

Flags: needinfo?(smartell)

Hi - wondering if there is any update on this? Do you know when we can expect to get the final strings?
thank you!

(In reply to Delphine Lebédel [:delphine - use need info] from comment #2)

Hi - wondering if there is any update on this? Do you know when we can expect to get the final strings?

Here are the proposed new strings, but they have not been finalized yet:

https://docs.google.com/document/d/1RF-h7po7YFqpHYeYwt-oYFvSU8Hypn9pAVHF7x_njcM/edit

I added some notes and questions about possibly reusing some similar existing strings (or using those strings as fallbacks at runtime for locales that don't have translations when we first ship).

Flags: needinfo?(smartell) → needinfo?(petru.lingurar)

(In reply to Chris Peterson [:cpeterson] from comment #3)

I added some notes and questions about possibly reusing some similar existing strings (or using those strings as fallbacks at runtime for locales that don't have translations when we first ship).

I have a meeting scheduled for tomorrow to get answers to my questions. I will keep you all posted.

See Also: → 1576170

New UX design screenshots and strings for New Tab card:
https://docs.google.com/document/d/1RF-h7po7YFqpHYeYwt-oYFvSU8Hypn9pAVHF7x_njcM/edit

Adding [fennec68.1.x] whiteboard tag because we'll want to ship this in a Fennec ESR 68.1.x dot release in mid-September. We won't be ready in time to ship in Fennec ESR 68.1 on September 3.

Priority: -- → P1
Whiteboard: [fennec68.1.x]
Depends on: 1576170
See Also: 1576170
Depends on: 1577868
Blocks: 1579217
Assignee: nobody → vlad.baicu
Alias: fennec-new-tab-signin
Depends on: 1580649
Depends on: 1584369
Depends on: 1584146
Keywords: checkin-needed

Comment on attachment 9094219 [details]
Bug 1570880 - Added Sign in buttons in Awesomescreen.r=petru

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Part of the new sign up buttons feature
  • User impact if declined: The sign up feature cannot be shipped without this patch
  • Fix Landed on Version:
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): This new feature will be validated with a PI request and has already undergone some testing.
  • String or UUID changes made by this patch:
Attachment #9094219 - Flags: approval-mozilla-esr68?

Please see https://bugzilla.mozilla.org/show_bug.cgi?id=1576170#c23 for the landing order of the sign up button feature patches.

Flags: needinfo?(petru.lingurar)

Comment on attachment 9094219 [details]
Bug 1570880 - Added Sign in buttons in Awesomescreen.r=petru

New Fennec awesomescreen work targeting 68.2. Approved for Fennec 68.2b6.

Attachment #9094219 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Depends on: 1586076
Whiteboard: [fennec68.1.x] → [fennec68.2]

Resolving as fixed because the New Tab buttons landed on ESR 68 in comment 10.

Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Regressions: 1586770

Verified as fixed on ESR 68.2b7, RC 68.2.0 build 2 with

  • Samsung Galaxy Tab S3 (Android 8);
  • OnePlus 5T (Android 9);
  • Prestigio Grace X5 (Android 4.4.2).
    I will mark this as verified. Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.