Closed Bug 1570903 Opened 1 year ago Closed 6 days ago

Perma [tier 2 - fission] leakcheck | tab 1752 bytes leaked (CondVar, Mutex, SchedulerEventTarget, TabGroup, ThrottledEventQueue, ...)

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M4.1

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell unknown])

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=259520868&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/YRbQjPa2Q2qXR8Q4NqHXvg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-02T05:08:59.366Z] 05:08:59 INFO - TEST-INFO | leakcheck | tab leaked 1 nsTArray_base
[task 2019-08-02T05:08:59.367Z] 05:08:59 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 1752 bytes leaked (CondVar, Mutex, SchedulerEventTarget, TabGroup, ThrottledEventQueue, ...)
[task 2019-08-02T05:08:59.368Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.369Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4574.log
[task 2019-08-02T05:08:59.369Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.372Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4574
[task 2019-08-02T05:08:59.373Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.374Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.375Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.376Z] 05:08:59 INFO - 0 |TOTAL | 37 0| 526603 0|
[task 2019-08-02T05:08:59.377Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.377Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 984 entries
[task 2019-08-02T05:08:59.378Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.379Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4684.log
[task 2019-08-02T05:08:59.380Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.381Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4684
[task 2019-08-02T05:08:59.381Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.382Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.383Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.385Z] 05:08:59 INFO - 0 |TOTAL | 46 0| 25512 0|
[task 2019-08-02T05:08:59.386Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.387Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 747 entries
[task 2019-08-02T05:08:59.388Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.389Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks.log
[task 2019-08-02T05:08:59.390Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.390Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 4408
[task 2019-08-02T05:08:59.391Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.392Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.393Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.394Z] 05:08:59 INFO - 0 |TOTAL | 45 0| 3638543 0|
[task 2019-08-02T05:08:59.403Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.403Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 1919 entries
[task 2019-08-02T05:08:59.404Z] 05:08:59 INFO - TEST-PASS | leakcheck | default no leaks detected!
[task 2019-08-02T05:08:59.405Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4474.log
[task 2019-08-02T05:08:59.405Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.406Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4474
[task 2019-08-02T05:08:59.407Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.407Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.408Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.409Z] 05:08:59 INFO - 0 |TOTAL | 42 0| 78938 0|
[task 2019-08-02T05:08:59.418Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.419Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 774 entries
[task 2019-08-02T05:08:59.420Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.421Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_gpu_pid4442.log
[task 2019-08-02T05:08:59.422Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.422Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, gpu process 4442
[task 2019-08-02T05:08:59.423Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.423Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.424Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.425Z] 05:08:59 INFO - 0 |TOTAL | 41 0| 40027 0|
[task 2019-08-02T05:08:59.425Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.426Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 280 entries
[task 2019-08-02T05:08:59.427Z] 05:08:59 INFO - TEST-PASS | leakcheck | gpu no leaks detected!
[task 2019-08-02T05:08:59.427Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4710.log
[task 2019-08-02T05:08:59.428Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.429Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4710
[task 2019-08-02T05:08:59.430Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.431Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.433Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.434Z] 05:08:59 INFO - 0 |TOTAL | 38 0| 170597 0|
[task 2019-08-02T05:08:59.435Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.435Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 777 entries
[task 2019-08-02T05:08:59.436Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.437Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4584.log
[task 2019-08-02T05:08:59.438Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.439Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4584
[task 2019-08-02T05:08:59.439Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.440Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.441Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.442Z] 05:08:59 INFO - 0 |TOTAL | 36 0| 136429 0|
[task 2019-08-02T05:08:59.447Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.448Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 964 entries
[task 2019-08-02T05:08:59.449Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.450Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4736.log
[task 2019-08-02T05:08:59.450Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.451Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4736
[task 2019-08-02T05:08:59.452Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.453Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.453Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.454Z] 05:08:59 INFO - 0 |TOTAL | 43 0| 29956 0|
[task 2019-08-02T05:08:59.458Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.459Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 769 entries
[task 2019-08-02T05:08:59.460Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.461Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4551.log
[task 2019-08-02T05:08:59.461Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.462Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4551
[task 2019-08-02T05:08:59.463Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.464Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.465Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.465Z] 05:08:59 INFO - 0 |TOTAL | 49 0| 17323 0|
[task 2019-08-02T05:08:59.468Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.469Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 412 entries
[task 2019-08-02T05:08:59.469Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.470Z] 05:08:59 INFO - leakcheck | Processing leak log file /tmp/tmpRDF9gv.mozrunner/runtests_leaks_tab_pid4496.log
[task 2019-08-02T05:08:59.471Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.472Z] 05:08:59 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4496
[task 2019-08-02T05:08:59.472Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.473Z] 05:08:59 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-02T05:08:59.474Z] 05:08:59 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-02T05:08:59.475Z] 05:08:59 INFO - 0 |TOTAL | 44 0| 38731 0|
[task 2019-08-02T05:08:59.479Z] 05:08:59 INFO -
[task 2019-08-02T05:08:59.480Z] 05:08:59 INFO - nsTraceRefcnt::DumpStatistics: 751 entries
[task 2019-08-02T05:08:59.481Z] 05:08:59 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2019-08-02T05:08:59.482Z] 05:08:59 INFO - runtests.py | Running tests: end.
[task 2019-08-02T05:08:59.502Z] 05:08:59 INFO - Buffered messages finished
[task 2019-08-02T05:08:59.503Z] 05:08:59 INFO - 0 INFO TEST-START | Shutdown
[task 2019-08-02T05:08:59.505Z] 05:08:59 INFO - 1 INFO Passed: 26795
[task 2019-08-02T05:08:59.506Z] 05:08:59 INFO - 2 INFO Failed: 0
[task 2019-08-02T05:08:59.507Z] 05:08:59 INFO - 3 INFO Todo: 144
[task 2019-08-02T05:08:59.508Z] 05:08:59 INFO - 4 INFO Mode: e10s
[task 2019-08-02T05:08:59.509Z] 05:08:59 INFO - 5 INFO SimpleTest FINISHED
[task 2019-08-02T05:08:59.510Z] 05:08:59 INFO - Buffered messages finished
[task 2019-08-02T05:08:59.511Z] 05:08:59 INFO - SUITE-END | took 843s
[task 2019-08-02T05:08:59.551Z] 05:08:59 INFO - Return code: 0
[task 2019-08-02T05:08:59.553Z] 05:08:59 ERROR - Got 1 unexpected statuses
[task 2019-08-02T05:08:59.554Z] 05:08:59 INFO - TinderboxPrint: mochitest-mochitest-plain-chunked<br/>667/<em class="testfail">1</em>/0
[task 2019-08-02T05:08:59.554Z] 05:08:59 WARNING - # TBPL WARNING #
[task 2019-08-02T05:08:59.554Z] 05:08:59 WARNING - setting return code to 1
[task 2019-08-02T05:08:59.555Z] 05:08:59 WARNING - The mochitest suite: mochitest-plain-chunked ran with return status: WARNING
[task 2019-08-02T05:08:59.556Z] 05:08:59 INFO - Running post-action listener: _package_coverage_data
[task 2019-08-02T05:08:59.556Z] 05:08:59 INFO - Running post-action listener: _resource_record_post_action
[task 2019-08-02T05:08:59.557Z] 05:08:59 INFO - Running post-action listener: process_java_coverage_data
[task 2019-08-02T05:08:59.557Z] 05:08:59 INFO - [mozharness: 2019-08-02 05:08:59.556092Z] Finished run-tests step (success)
[task 2019-08-02T05:08:59.558Z] 05:08:59 INFO - Running post-run listener: _resource_record_post_run
[task 2019-08-02T05:08:59.648Z] 05:08:59 INFO - Validating Perfherder data against /builds/worker/workspace/mozharness/external_tools/performance-artifact-schema.json
[task 2019-08-02T05:08:59.655Z] 05:08:59 INFO - PERFHERDER_DATA: {"framework": {"name": "job_resource_usage"}, "suites": [{"subtests": [{"name": "cpu_percent", "value": 81.89045667447301}, {"name": "io_write_bytes", "value": 1651441664}, {"name": "io.read_bytes", "value": 27467776}, {"name": "io_write_time", "value": 59224}, {"name": "io_read_time", "value": 524}], "extraOptions": ["e10s", "taskcluster-m3.large"], "name": "mochitest.mochitest-plain-chunked.8.overall"}, {"subtests": [{"name": "time", "value": 11.750900030136108}, {"name": "cpu_percent", "value": 50.50909090909091}], "name": "mochitest.mochitest-plain-chunked.8.install"}, {"subtests": [{"name": "time", "value": 0.0013780593872070312}], "name": "mochitest.mochitest-plain-chunked.8.stage-files"}, {"subtests": [{"name": "time", "value": 844.4744131565094}, {"name": "cpu_percent", "value": 82.33539192399046}], "name": "mochitest.mochitest-plain-chunked.8.run-tests"}]}
[task 2019-08-02T05:08:59.655Z] 05:08:59 INFO - Total resource usage - Wall time: 856s; CPU: 82.0%; Read bytes: 27467776; Write bytes: 1651441664; Read time: 524; Write time: 59224
[task 2019-08-02T05:08:59.657Z] 05:08:59 INFO - TinderboxPrint: CPU usage<br/>82.3%
[task 2019-08-02T05:08:59.657Z] 05:08:59 INFO - TinderboxPrint: I/O read bytes / time<br/>27,467,776 / 524
[task 2019-08-02T05:08:59.657Z] 05:08:59 INFO - TinderboxPrint: I/O write bytes / time<br/>1,651,441,664 / 59,224
[task 2019-08-02T05:08:59.658Z] 05:08:59 INFO - TinderboxPrint: CPU idle<br/>298.9 (17.7%)
[task 2019-08-02T05:08:59.659Z] 05:08:59 INFO - TinderboxPrint: CPU system<br/>131.8 (7.8%)
[task 2019-08-02T05:08:59.659Z] 05:08:59 INFO - TinderboxPrint: CPU user<br/>1,252.2 (74.3%)
[task 2019-08-02T05:08:59.660Z] 05:08:59 INFO - TinderboxPrint: Swap in / out<br/>0 / 0
[task 2019-08-02T05:08:59.661Z] 05:08:59 INFO - install - Wall time: 12s; CPU: 51.0%; Read bytes: 0; Write bytes: 4366336; Read time: 0; Write time: 320
[task 2019-08-02T05:08:59.662Z] 05:08:59 INFO - stage-files - Wall time: 0s; CPU: Can't collect data; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
[task 2019-08-02T05:08:59.669Z] 05:08:59 INFO - run-tests - Wall time: 844s; CPU: 82.0%; Read bytes: 27467776; Write bytes: 1647075328; Read time: 524; Write time: 58904
[task 2019-08-02T05:08:59.871Z] 05:08:59 WARNING - returning nonzero exit status 1

Kris, please take a look over this. Looks to be from https://hg.mozilla.org/mozilla-central/rev/2bdc5f8ac30e97669e25172063c1ce8a9cfe16a3 after Bug 1569832 got into central.

Flags: needinfo?(kmaglione+bmo)
Summary: Intermittent leakcheck | tab 1752 bytes leaked (CondVar, Mutex, SchedulerEventTarget, TabGroup, ThrottledEventQueue, ...) → Perma [tier 2 - fission] leakcheck | tab 1752 bytes leaked (CondVar, Mutex, SchedulerEventTarget, TabGroup, ThrottledEventQueue, ...)
Regressed by: 1570207
Regressed by: 1566186
No longer regressed by: 1570207
No longer regressed by: 1566186
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Priority: -- → P2

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Fission Milestone: ? → M4.1

Sending to Fission triage. We haven't had any test failures since August 2019.

I can't tell from reading this bug which test is leaking. Did kmag disable the leaking test in bug 1566186 (mentioned in comment 3)?

Fission Milestone: M4.1 → ?

(In reply to Chris Peterson [:cpeterson] from comment #8)

Sending to Fission triage. We haven't had any test failures since August 2019.

Closing as WFM

Status: REOPENED → RESOLVED
Fission Milestone: ? → M4.1
Closed: 1 year ago6 days ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.