Closed Bug 1571016 Opened 3 years ago Closed 3 years ago

Sites can detect when Firefox is in private mode, but not Chrome

Categories

(Core :: Storage: IndexedDB, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 781982

People

(Reporter: michael.bacarella, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

It appears sites can detect when Firefox is in private browsing mode, but not when Chrome is in incognito mode.

Example: open any New York Times (nytimes.com) article link in Private Mode.

Actual results:

nytimes.com detects that you're in private mode and refuses to show you the article until you log in.

Expected results:

It should do what happens when you view in Chrome Incognito. The site fails to detect that you're in Incognito mode, shows you the article, and tells you that you have N free articles left for the month.

Status: UNCONFIRMED → RESOLVED
Type: enhancement → defect
Closed: 3 years ago
Component: Untriaged → DOM: IndexedDB
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 781982
You need to log in before you can comment on or make changes to this bug.