new mail deleted by context menu does not cancel system tray biff

RESOLVED DUPLICATE of bug 232104

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 232104
16 years ago
7 years ago

People

(Reporter: emmet, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020623
BuildID:    2002062308

New mail arrives, the system tray icon appears. Open up the mail news window and
delete the new mail using the context menu->delete. The message goes into trash
*unread* and the system tray icon does not disappear. It should.

Reproducible: Always
Steps to Reproduce:

Updated

16 years ago
QA Contact: huang → stephend

Comment 1

15 years ago
*** Bug 188172 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Emmet: IMAP or POP?
I was able to duplicate this for POP with 1.3 Final and with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030426

In addition to your symptom, I can add that once the mail is cleared

I could find no dupes of this bug, altho it is closely related to a lot of 
notification bugs:  Bug 46133, Bug 107206, Bug 136868.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Another close relation: bug 46133

Comment 4

15 years ago
Sorry, I meant: another close relation is Bug 116181.

(Please ignore my sentence fragment in the middle of comment 2.)

Besides clearing the biff icons, the deleted message should also be marked as 
read -- this would be consistent with filters, which (when deleting incoming 
mail) mark the message as read.

Comment 5

15 years ago
*** Bug 211243 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Updating component
Assignee: mscott → sspitzer
Component: Networking: MailNews General → Mail Notification

Updated

14 years ago
Blocks: 36011

Comment 7

14 years ago
See bug 232104: Biff notification flags are also not cleared when
  Tools -> Delete mails marked as junk in this folder
is used to remove new junk from the Inbox.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Please note that I attached a patch to bug 232104 that could or could not fix
this bug in a way that may or may not be satisfactory, and it could use some
testing.

Comment 9

13 years ago
*** Bug 316027 has been marked as a duplicate of this bug. ***
this is also present in thunderbird since at least 1.0, that's when i started noticing it.

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
Assignee: mail → nobody
QA Contact: search → message-display

Comment 11

7 years ago
Wayne, this sounds like a MailNews::Core problem? And/or DUP to bug 232104 ?

Comment 12

7 years ago
does sound the same. please reopen if bug 232104 does not fix
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Depends on: 232104
Resolution: --- → DUPLICATE
Duplicate of bug: 232104
You need to log in before you can comment on or make changes to this bug.