Closed Bug 1571156 Opened 1 year ago Closed 2 months ago

Intermittent WebRtcIceConnectTest.TestConnectRestartIce | Expected equality of these values:

Categories

(Core :: WebRTC: Networking, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox-esr68 --- wontfix
firefox-esr78 --- fixed
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bwc)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=259734563&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/eCCREvkoQ5ibAk-Y__8zQw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-03T01:46:53.255Z] 01:46:53 INFO - ICE-PEER(P2:default): all checks completed success=1 fail=0
[task 2019-08-03T01:46:53.255Z] 01:46:53 INFO - STUN-CLIENT(raX2|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|prflx)): Received response; processing
[task 2019-08-03T01:46:53.255Z] 01:46:53 INFO - ICE-PEER(P3:default)/CAND-PAIR(raX2): setting pair to state SUCCEEDED: raX2|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|prflx)
[task 2019-08-03T01:46:53.255Z] 01:46:53 INFO - ICE-PEER(P3:default)/STREAM(P3:stream0 - P3-34-ufrag:P3-34-pwd)/COMP(1)/CAND-PAIR(raX2): nominated pair is raX2|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|prflx)
[task 2019-08-03T01:46:53.255Z] 01:46:53 INFO - ICE-PEER(P3:default)/STREAM(P3:stream0 - P3-34-ufrag:P3-34-pwd)/COMP(1)/CAND-PAIR(raX2): cancelling all pairs but raX2|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|prflx)
[task 2019-08-03T01:46:53.255Z] 01:46:53 INFO - ICE-PEER(P3:default)/STREAM(P3:stream0 - P3-34-ufrag:P3-34-pwd)/COMP(1)/CAND-PAIR(raX2): cancelling FROZEN/WAITING pair raX2|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|prflx) in trigger check queue because CAND-PAIR(raX2) was nominated.
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - ICE-PEER(P3:default)/CAND-PAIR(raX2): setting pair to state CANCELLED: raX2|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|prflx)
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - ICE-PEER(P3:default)/STREAM(P3:stream0 - P3-34-ufrag:P3-34-pwd)/COMP(1)/CAND-PAIR(9beH): cancelling FROZEN/WAITING pair 9beH|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|candidate:0 1 UDP 2122252543 10.51.56.93 53076 typ host) because CAND-PAIR(raX2) was nominated.
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - ICE-PEER(P3:default)/CAND-PAIR(9beH): setting pair to state CANCELLED: 9beH|IP4:10.51.56.93:58502/UDP|IP4:10.51.56.93:53076/UDP(host(IP4:10.51.56.93:58502/UDP)|candidate:0 1 UDP 2122252543 10.51.56.93 53076 typ host)
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - ICE-PEER(P3:default)/ICE-STREAM(P3:stream0 - P3-34-ufrag:P3-34-pwd): all active components have nominated candidate pairs
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - ICE-PEER(P3:default): all checks completed success=1 fail=0
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - P3: sent 4 bytes
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - P2: received 4 bytes
[task 2019-08-03T01:46:53.256Z] 01:46:53 INFO - P3 Shutdown
[task 2019-08-03T01:46:54.332Z] 01:46:54 INFO - P1 Shutdown
[task 2019-08-03T01:46:55.414Z] 01:46:55 INFO - P2 Shutdown
[task 2019-08-03T01:46:56.431Z] 01:46:56 WARNING - TEST-UNEXPECTED-FAIL | WebRtcIceConnectTest.TestConnectRestartIce | test completed (time: 3265ms)

This looks like a pretty consistent intermittent failure across various releases for awhile now. Any ideas what we might be able to make it more reliable?

Flags: needinfo?(docfaraday)
Assignee: nobody → docfaraday
Flags: needinfo?(docfaraday)

Try looks good so far. Going to retrigger some more.

Yeah, not seeing this intermittent anymore on that try push.

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/86cd650f32c3
Wait for streams to be ready before trying to send packets. r=mjf
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.