Closed Bug 1571214 Opened 3 months ago Closed 2 months ago

Video is shifted down in Picture-in-Picture player window

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: winson.wen1, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

  1. Open http://asianwiki.com/Your_Lie_in_April, or any other page with trailer on asianwiki.com
  2. Scroll down the trailers section of the page and play one
  3. Toggle PiP

Actual results:

Video is shifted down in the PiP window, with the bottom cut off and white space at the top.

Expected results:

Video is properly positioned.

This might be a dupe of Bug 1550002 but it doesn't mention the bottom being cut off so I'm not sure.

Blocks: 1527926
Priority: -- → P2
Assignee: nobody → mconley
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f553ffa3787
Make sure to strip any element styles on the cloned <video> before inserting into the Picture-in-Picture player window. r=JSON_voorhees
https://hg.mozilla.org/integration/autoland/rev/f4201a5b783a
Regression test. r=JSON_voorhees
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1550002

Hey Winson,

Wanted to verify the fix for this issue but was quite confused on how did PiP work on this video first of all. For me, it uses Flash player and last time I checked PiP does not support Flash video players. Did you enforce PiP somehow or I am missing out something?

Flags: needinfo?(winson.wen1)

Hmm, video plays fine without Flash for me, and I didn't have to change anything to get PiP to work. I don't have Flash installed though, so maybe the website is offering a Flash video because you have it installed?

Flags: needinfo?(winson.wen1)

Thanks Winson!
Indeed flash was the problem here, uninstalled it and now I can play the video and PiP also works on the latest Beta 70.0b7 (64-bit) on Windows 10 x64.

Closing this as Verified - Fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.