Closed Bug 1571435 Opened Last month Closed Last month

A part of the Special Monitor Snippet is highlighted a second time when the "x" button is hovered on Dark Theme

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox68 --- unaffected
firefox69 --- fixed
firefox70 --- verified

People

(Reporter: cmuresan, Assigned: emcminn)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

[Affected versions]:

  • Firefox Nightly 70.0a1, Build ID 20190805095413

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have the browser.newtabpage.activity-stream.asrouter.devtoolsEnabled pref set to true.
  • The browser's dark theme is set.

[Steps to reproduce]:

  1. Start the browser with a new clean profile.
  2. Open a new tab and trigger the Special Monitor snippet.
  3. Hover the "x" snippet button and observe the behavior.

[Expected results]:

  • Part of the snippet is highlighted a second time.

[Actual results]:

  • Only one highlight effect is displayed.

[Notes]:

  • The issue is not reproducible on Default or Light themes.
  • Attached a screen recording of the issue.
Assignee: nobody → emcminn
Iteration: --- → 70.3 - Aug 5 - 18
Keywords: github-merged
Priority: -- → P1
Blocks: 1571115
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (70.0a1 Build ID - 20190809095611) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, only one highlight effect is displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.