Closed Bug 1571441 Opened 4 months ago Closed 4 months ago

The Special Monitor Snippet is not resized correctly when the browser window is resized

Categories

(Firefox :: Messaging System, defect, P1, critical)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox68 --- unaffected
firefox69 --- verified
firefox70 --- verified

People

(Reporter: cmuresan, Assigned: emcminn)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

[Affected versions]:

  • Firefox Nightly 70.0a1, Build ID 20190805095413

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have the browser.newtabpage.activity-stream.asrouter.devtoolsEnabled pref set to true.

[Steps to reproduce]:

  1. Start the browser with a new clean profile.
  2. Open a new tab and trigger the Special Monitor snippet.
  3. Resize the Browser window to half screen and observe the snippet.
  4. Resize the Browser to the minimum width and observe the snippet.

[Expected results]:

  • Step 3: The "x" button is displayed outside of the snippet area.
  • Step 4: Most of the message is displayed outside of the snippet area.

[Actual results]:

  • Step 3 & 4: The snippet is resized accordingly.

[Notes]:

  • The issue is also reproducible with Discovery Stream on. But in this case the Snippet should not be resized as the whole page does not support any other browser size.
  • Attached a screen recording of the issue.
Assignee: nobody → emcminn
Iteration: --- → 70.3 - Aug 5 - 18
Keywords: github-merged
Priority: -- → P1
Blocks: 1571115
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

This issue is partially fixed, now the message is correctly displayed inside the snippet's area, but the "x" button is still displayed outside of it. Also, the snippet's icon is no longer displayed after resize.

Considering the above I am reopening this issue.

Tested with the latest Firefox Nightly (70.0a1 Build ID - 20190809095611) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

This should be resolved by this follow-up bug now, please let me know if anything else comes up!

We'll track the additional work in bug 1572463

Blocks: 1572463
Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Regressions: 1575523

I have verified that the issue is no longer reproducible on the latest Firefox Release 69, Beta 70.0b4, and Nightly 71.0a1 on Windows 10, macOS 10.14, and Arch Linux 14.4.3.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.