[PP]Changing text format from buttons changes text area

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When you type characters in the editor and change the format to Bold, Italic, or
Underline from clicking the tool buttons in the same line, it works fine.
However, after you go to the next line to do the same as the first line, the
characters you type in the second line move to the first line.

Steps of reproduce
1. Open the HTML editor by selecting menu Task|Editor
2. Type "aaa" and select the characters
3. Click on Bold button
4. Hit enter to go to the next line
5. Type "bbb" and select the characters
6. Click on Bold button
Notice that "bbb" move to just after "aaa" in the first line.

If you select the menu Format|Style->Bold to change the format, this does not
happen.

Tested 10-06 Win32 M11 build.  This does not happen in Linux build.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 1

19 years ago
I can't reproduce this.  Could you please give more detailed description of how
to reproduce.  I know it sounds like a pain, but I need to know exactly what
keystrokes you're typing, what mouseclicks you use, and where you're selection
is inside the document.  Are you starting from a blank document or the editor
test document? If the test document, where is your initial selection?  In step
4, do you still have "aaa" selected so that the ENTER deletes them, or is that
an oversight in your description?
Sorry to be such a pain.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
verified in 10/12 build.
You need to log in before you can comment on or make changes to this bug.